phpmyadmin Error ISPConfig3.0.1.3

Discussion in 'General' started by pinguinito, Feb 26, 2010.

  1. pinguinito

    pinguinito New Member

    Welcome to phpMyAdmin

    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

    MySQL said: Documentation
    #1045 - Access denied for user 'root'@'localhost' (using password: NO)
    Open new phpMyAdmin windowOpen new phpMyAdmin window

    What can I do??
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the file /etc/phpmyadmin/ The file looks like this on my debian lenny test server:

     * Debian local configuration file
     * This file overrides the settings made by phpMyAdmin interactive setup
     * utility.
     * For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz
     * NOTE: do not add security sensitive data to this file (like passwords)
     * unless you really know what you're doing. If you do, any user that can
     * run PHP or CGI on your webserver will be able to read them. If you still
     * want to do this, make sure to properly secure the access to this file
     * (also on the filesystem level).
     * Server(s) configuration
    $i = 0;
    // The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].
    // You can disable a server config entry by setting host to ''.
    /* Authentication type */
    //$cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    //$cfg['Servers'][$i]['host'] = 'localhost';
    //$cfg['Servers'][$i]['connect_type'] = 'tcp';
    //$cfg['Servers'][$i]['compress'] = false;
    /* Select mysqli if your server has it */
    //$cfg['Servers'][$i]['extension'] = 'mysql';
    /* Optional: User for advanced features */
    // $cfg['Servers'][$i]['controluser'] = 'pma';
    // $cfg['Servers'][$i]['controlpass'] = 'pmapass';
    /* Optional: Advanced phpMyAdmin features */
    // $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
    // $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    // $cfg['Servers'][$i]['relation'] = 'pma_relation';
    // $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    // $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    // $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    // $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    // $cfg['Servers'][$i]['history'] = 'pma_history';
    // $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
     * End of servers configuration
     * Directories for saving/loading files from server
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';
  3. pinguinito

    pinguinito New Member

    phpmyadmin ispconfig 3

    Yes I check the file and is all right.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    But then you wont get tghis error. Which auth type have you set in your phpmyadmin configuration? It muste bei either cookie or http
  5. pinguinito

    pinguinito New Member

    phpmyadmin problem fixed

    thanks till I set up for auth type cookies and it is working.
    thank you very mush
    Now my phpMyAdmin is working and I can see my data.
    But still I have this messenger:

    Invalid hostname for server 1. Please review your configuration.

    Last edited: Feb 27, 2010

Share This Page