phpmyadmin broke my existing vhosts

Discussion in 'Installation/Configuration' started by theotherguy81, Jun 18, 2014.

  1. theotherguy81

    theotherguy81 New Member

    edit to fix brain malfunction: damnit... ispconfig broke my vhosts.. not phpmyadmin

    hi all..

    I've build up my own Ubuntu 14.04, Apache web server and i had already set up several virtual hosts when i discovered ispconfig...

    so, I installed ispconfig and everything still worked... I made a virtual host within ispconfig, tested to see if it was active and removed it again and now none of my virtual hosts that already existed are working...

    now the only vhost that works for me is my phpadmin

    trying all the others, my web browser gives me this... "You don't have permission to access / on this server." (including https://lmydns:8080 being ispconf)

    i checked the log files and this is the error i get:

    [Wed Jun 18 11:25:45.587569 2014] [autoindex:error] [pid 8779] [client] AH01276: Cannot serve directory /usr/share/wordpress: No matching DirectoryIndex (index.php) found, and server-generated directory index forbidden by Options directive

    so I've tried adding a .htaccess file in a few directories containing "options +indexes" (an possible solution I Google'd down) which hasn't worked.

    i cant seem to find any other possible solutions... any one had this issue who can help?

    many thanks


    EDIT2: i feel i should add that in every site directory is laid out with /site/cgi-bin, /site/html, /site/logs, and a text index file in /site/html saying this is a test page for "site"
    Last edited: Jun 18, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig requires a empty server to install it, you can not intall ISPConfig on a server that is running websites already as your existing sites create a conflict with the ispconfig vhost configuration.

    To fix your issue, make a backup of your manually created websites, then delete your manually created website config and recreate the sites in ispconfig. Then copy the website contant into the web directories of the sites that you created in ispconfig.
  3. theotherguy81

    theotherguy81 New Member

    ahh thats no real issue as i had planed to do this anyways...

    EDIT: i just wanted to fix my issue first

    thanks till
    Last edited: Jun 18, 2014

Share This Page