Phpmyadmin and webmail not opening [SOLVED]

Discussion in 'General' started by Udson Assis, Mar 6, 2022.

  1. Udson Assis

    Udson Assis New Member

    Friends,

    I cannot access webmail nor phpmyadmin from the domain.

    I get the following message: File not found.

    Captura de tela de 2022-03-06 15-22-46.png Captura de tela de 2022-03-06 15-22-03.png
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which tutorial did you use to install the server? And is this an Apache or Nginx server?
     
  3. Udson Assis

    Udson Assis New Member

    Tutorial: Perfect Server Automated ISPConfig 3 Installation on Debian 10 - 11 and Ubuntu 20.04
    OS: Debian 11
    Apache
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did you do something in addition to what the Autoinstaller instructions tell you to do? Was the server empty before autoinstaller started? Do webmail or phpmyadmin work with plain http:// connection?
     
    Last edited: Mar 6, 2022
  5. Udson Assis

    Udson Assis New Member

    I didn't do anything other than what the tutorial says.

    The server was installed from scratch.

    Does not work with http

    Captura de tela de 2022-03-06 20-56-15.png
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, that's strange. Are you sure that this domain name points to the correct server? Please try using the server hostname instead.
     
  7. Udson Assis

    Udson Assis New Member

    The domain name pointing to the server is correct.

    With the hostname of the server it works as shown in the images below.

    Captura de tela de 2022-03-07 13-47-50.png Captura de tela de 2022-03-07 13-46-58.png
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have php chroot enabled in that site? If yes, it might prevent access to tools like phpmyadmin and webmail.
     
    Th0m likes this.
  9. Udson Assis

    Udson Assis New Member

    The php chroot was turned on. After I turned it off they worked.
    Thank you for your help.
     
  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    It's better to turn it on and enable a redirect for phpMyAdmin.
     
  11. Udson Assis

    Udson Assis New Member

    Thanks for the feedback, how do I do this redirect?
     
  12. Udson Assis

    Udson Assis New Member

    how to redirect phpmyadmin and webmail when php chroot is enabled?
     
  13. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I create a global redirect for those in web server config, it has nothing to do with the site's PHP setup as you are redirecting to a different site.
     
  14. Udson Assis

    Udson Assis New Member

    How can I do this through ISPConfig?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You can enter Apache and Nginx redirect rules in the apache/nginx directives field on the options tab of the website.
     
    Udson Assis likes this.
  16. Udson Assis

    Udson Assis New Member

    Perfect, everything working as I wanted!
    I'll leave it documented below how I did it.
    Redirect to phpmyadmin and webmail if php chroot is enabled:
    Note:
    My server is running apache
    Access your ISPConfig and go to Sites, choose domain -> options -> apache directives:
    Add the line below replacing source and destination.
    Redirect permanent /source destination
    Example:
    Redirect permanent /phpmyadmin https://server1.example.com:8080/phpmyadmin/
    Redirect permanent /webmail https://server1.example.com:8080/webmail/
     
    Last edited: Mar 11, 2022
    Taleman likes this.
  17. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I would not add a permanent redirect. If the phpmyadmin/webmail location ever changes for that domain, you are in trouble because of the cached redirects. So remove the permanent statement.
     
    ahrasis likes this.

Share This Page