phpmyadmin and squirrelmail are 404 & ClamAV is outdated

Discussion in 'General' started by kvand, Jun 18, 2009.

  1. kvand

    kvand New Member


    First of all, I would like to compliment Falko on writing "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]" everything went smoothly on the install (especially for a Linux newbie like me :)). However, several issues have popped up:

    1)When using my hostname ( in the URL bar of a web browser, I get a "Server Not Found" error.

    2)When using my external ip I can access ISPConfig 3, but not Squirrelmail or phpmyadmin.

    3)ClamAV is "Out of date" and I have no idea how to update from v0.95.1 to v0.95.2.

    4)Also, this is minor but I figured I should mention it: the mod_rewrite Apache module is not working with Permalinks in Wordpress (v2.8).

    Again, I'm a complete newbie to Linux and I know this is all pretty vague...If you would like me to copy/paste some output from commands up here I will be more than glad to oblige.

    Thank you very much.
    Last edited: Dec 6, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) make sure that the hostname existsb in dns.
    2) But you can access them with the internal IP?
    3) thats ok. You have the latest avalable version for ubuntu already installed the antivirus signatures are up to date.
    4) Thats normal too. Switch to suphp os php-fcgi + suexec.
  3. kvand

    kvand New Member

    1) How would I go about checking? Is there a specific command I should use or file I should check?

    2)Yes, both the internal and external IP addresses work. I get an error when using get a 404 whenever I try my IP + /webmail or /phpmyadmin.


    4)I'm using SuPHP at the moment.
    Last edited: Jun 19, 2009
  4. danielborene

    danielborene New Member

    - Are you trying to access from a computer outside of the network, inside of the network or local-host(The actual Server)

    - make sure you have a phpmyadmin.conf under /etc/apache2/conf.d/

    - Make sure you have the link folder webmail under /var/www
    - Make sure the link is pointing to the right folder. /usr/share/squirrelmail/
    Type ls -la /var/www and it will show you the link of webmail

    I'm actually using RoundCube 0.2.2 which is much nicer than squirrelmail, and it is working beautifully.
    The installation of RoundCube I followed actually adds the /webmail to every virtual host you create, with squirrelmail you have to create a link manually to each website you add.
    If you like I can post the instructions on how to setup RoundCube email.
  5. KillerSneak

    KillerSneak New Member

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have to use a port or not depends on the setup and Linux distribution.
  7. KillerSneak

    KillerSneak New Member

    Well i followed the 11.1 SuSe + IPS3 tutorial and this is the only way i can access it.

    Another problem i have is that from a clients control panel:
    When trying to access webmail (squirrel mail) it gets indeed the 404 <- this link isn't correct and should be
    Any way to fix this?

    I'm writing up a 11.1 + ISP3 config for SuSe x64 but i need some bugs / issues solved before i can try and share it. At this moment the documentation as here on the site is incomplete and the ISP3 documentation itself is even worse (no pun intened)

    Like now my clients can receive E-mail from who and where ever but still can't send e-mails?

    Another thing / request
    Maybe usefull to show clients/users here how they can get everything woring when they have registerd a domain @ godaddy and want to run ISP3 with it. as I don't fully understand the Total DNS controll at godaddy and how to incorp nameservers ? I understand i need 2 seperate IP adresses? While this isn't being said anywhere in any tutorials here.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Just installed it on friday on OpenSuSE 11.1 with the guide and it worked out of the box, no bugs or issues. What are the exact problems that you have?
  9. KillerSneak

    KillerSneak New Member

    the problem is -> should direct to Squirrelmail not? -> should direct to PhpMyAdmin not?

    in my case it's

    And the link in the client's panel to goto the webmail doesn't work but get's directed to:
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. KillerSneak

    KillerSneak New Member

    Don't think it's appropiate to link to a plugin that doesn't seem to work?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Dont you think ist appropriate to post this instead of reading my whole post?

    The plugin works as good as it is possible with this approach. If you would have read my post then you should know why and when it works and when not and wehen to use one of the other solutions that I mentioned.
  13. kvand

    kvand New Member

    I have tried accessing from both the internal network and from outside, both to no avail.

    I do not have a phpmyadmin.conf there, what should I do?

    All the links and such are there, and they're pointing to the correct locations...What should I do?
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the domains does not exist. Create A DNS A-Record for pointing to the IP address of your webserver.
  15. kvand

    kvand New Member

    Does it take a while for the new DNS records to take effect? I added a new zone, an A-Record, and an alias for "". So far it has not had any effect.

    What should I do?

    Sorry for the headache Till, and thank you for your help in this matter. It is very much appreciated. :)
  16. falko

    falko Super Moderator ISPConfig Developer

    Yes, it can take up to 72 hours until DNS changes propagate.
  17. kvand

    kvand New Member

    The DNS record that I put into the server did not change anything. I was unable to access "" internally and externally.

    Perhaps I entered the DNS record wrong?
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    First, make sure that you enter the record on the correct server. This is mots likely the server of the provider were you registered and not your local server. Then you will have to wait some time as falko mentioned above.
  19. kvand

    kvand New Member

    Alrighty, I made an A-Record on my DNS service and "" is a valid URL now. However, Squirrelmail and phpmyadmin are still 404 when I try "" and "".
  20. F4LLEN

    F4LLEN New Member

    I too am missing the phpmyadmin.conf under /etc/apache2/conf.d/, can someone please enlighten me on where to obtain this file? assuming that this is the reason why my phpmyadmin is returning a 404?

Share This Page