(phpmyadmin) Access denied for user...

Discussion in 'Installation/Configuration' started by Thomas Jensen, Aug 9, 2009.

  1. Thomas Jensen

    Thomas Jensen New Member

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you modify the config.php file of your phpMyAdmin installation? In any case, you should check if the settings in there are correct.
     
  3. Thomas Jensen

    Thomas Jensen New Member

    I'am pretty sure i didn't, but where can these files be found?
     
  4. Thomas Jensen

    Thomas Jensen New Member

    The content of my config.inc.php file is commented out, but it hasn't been modified.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    There must be a problem with the config.inc.php file, please check it and make sure that it does not uses e.g. the "session" option for authentication and not "config".
     
  6. Thomas Jensen

    Thomas Jensen New Member

    This is the content of config.inc.php:

    <?php
    /**
    * Debian local configuration file
    *
    * This file overrides the settings made by phpMyAdmin interactive setup
    * utility.
    *
    * For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz
    *
    * NOTE: do not add security sensitive data to this file (like passwords)
    * unless you really know what you're doing. If you do, any user that can
    * run PHP or CGI on your webserver will be able to read them. If you still
    * want to do this, make sure to properly secure the access to this file
    * (also on the filesystem level).
    */

    /**
    * Server(s) configuration
    */
    $i = 0;
    // The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use $cfg['Servers'][0].
    // You can disable a server config entry by setting host to ''.
    $i++;

    /* Authentication type */
    //$cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    //$cfg['Servers'][$i]['host'] = 'localhost';
    //$cfg['Servers'][$i]['connect_type'] = 'tcp';
    //$cfg['Servers'][$i]['compress'] = false;
    /* Select mysqli if your server has it */
    //$cfg['Servers'][$i]['extension'] = 'mysql';
    /* Optional: User for advanced features */
    // $cfg['Servers'][$i]['controluser'] = 'pma';
    // $cfg['Servers'][$i]['controlpass'] = 'pmapass';
    /* Optional: Advanced phpMyAdmin features */
    // $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
    // $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    // $cfg['Servers'][$i]['relation'] = 'pma_relation';
    // $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    // $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    // $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    // $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    // $cfg['Servers'][$i]['history'] = 'pma_history';
    // $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

    /*
    * End of servers configuration
    */

    /*
    * Directories for saving/loading files from server
    */
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok so far. And you are sure that you have installed a copy of phpmysdmin in the website spilcomputer.dk? Otherwise it might just be that you assigned the IP to another website which will make the globaly installed phpmyadmin inaccessible.
     
  8. Thomas Jensen

    Thomas Jensen New Member

    There is no other copies of PHPmyadmin, as far as i know, and I've just ran through my list of websites and none of them has an IP assigned.
    I can't access PHPmyadmin from any of my domains (eg. server1.xxxxx.dk/phpmyadmin)
     
  9. Thomas Jensen

    Thomas Jensen New Member

    I solved the problem by uncommenting the line:
    /* Authentication type */
    //$cfg['Servers'][$i]['auth_type'] = 'cookie';
     

Share This Page