phpmyadmin - 404 not found => Debian 9.3 - ISPCONFIG 3

Discussion in 'ISPConfig 3 Priority Support' started by Yoann, Jan 11, 2018.

  1. Yoann

    Yoann New Member

    Hi there, a happy new year to you all!

    I've installed The Perfect Server - Debian 9 (Stretch) on an ovh server (1 month ago) => https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/

    I created several sites and I had access to phpmyadmin but today I can not anymore. I get a 404 error. What has changed since the last time I went to phpmyadmin is maybe that I added network interfaces (IP address) to the server, so I could point each site to a different IP address.

    However I have Wordpress sites which are accessible and are working online.
    And I don't want to reinstall phpmyadmin because I have to make a backup before ...

    In my /etc/phpmyadmin/apache.conf
    I have an alias
    # phpMyAdmin default Apache configuration
    Alias /phpmyadmin /usr/share/phpmyadmin

    I don't know what to do... and why it's dont work

    Thank you for your help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Yoann

    Yoann New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    phpmyadmin is never reachable on port 8080 on an ISPConfig server, so it is correct that the URL has not 8080 inside.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Run this command to ensure that you enabled phpmyadmin config in apache:

    a2enconf phpmyadmin

    and then restart apache.

    service apache2 restart
     
  6. Yoann

    Yoann New Member

    I've got this error : Conf phpmyadmin does not exist!
     
  7. Yoann

    Yoann New Member

    Code:
    /etc/phpmyadmin# ls
    apache.conf  conf.d  config-db.php  config.footer.inc.php  config.header.inc.php  config.inc.php  htpasswd.setup  lighttpd.conf  phpmyadmin.desktop  phpmyadmin.service
    
    when i open /etc/phpmyadmin/conf.d it's empty. I think I created it by using nano command
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The apache.conf file is created by the phpmyadmin debian package. Seems as if the symlink in apache conf-available has been removed. Run these commands:

    ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
    a2enconf phpmyadmin
    service apache2 restart
     
  9. Yoann

    Yoann New Member

    You are my hero !
    I'm now able to access phpmyadmin with any of the ip addresses
    Both work, with or without :8080
    But link from ISPCONFIG is with :8080

    Thank you so much Till, again ^^
     
  10. downsouth

    downsouth New Member

    Hi
    Just to let you know that I followed same tutorial and have same problem which was fixed by your suggested commands. Seems as if there might be some sort of issue around this?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no issue with the tutorial, you just did no activate the Apache option during phpMyAdmin installation as described in the tutorial. an option in apt is activated by using the space bar of your keyboard, it is not enough to highlight the option by navigation to it with the arrow keys.
     
  12. downsouth

    downsouth New Member

Share This Page