phpmailer not working on Centos Webserver

Discussion in 'Server Operation' started by drbeat, Apr 24, 2012.

  1. drbeat

    drbeat New Member

    Hi all,

    Total Linux newbie here so please forgive my stupidity and fumbling! Sorry about the title but I'm at a slight loss to describe what my issue could be!

    Back Story: Company I work for has decided to bring our external webhosting inhouse. I created a Centos VM based on this 'How to' article (The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]) hosting works perfect and I would have been lost without this guide! I have followed the article to the word! Websites work fine externally and internally.

    Issue: some of the sites use PHP based 'contact us' forms which use a php file called class.phpmailer.php. These php based forms have ceased working since uploading the website files from the old external host to the company internal Centos box. Obviously there is a config difference between the external host's box and my Centos box but that is all I can figure out! :mad: When I use the forms, they appear to execute with the usual "thanks for your message, we'll get back to you" so no errors? In fact I don't where else to look for errors? The contact email addresses on the 'contact-us.htm' $mail (who the form contents are sent to) entries are correct but the users are not getting anything from the forms.

    I'd like the class.phpmailer.php file to pass messages to our internal Exchange 2010 server which is enabled as an internal smtp relay for the webserver but, again, I cannot figure out how to do that.

    The details of this class.phpmailer.php file is as following:

    I've also attached the full file too.

    Sorry for being such a newb, this seems like it should be pretty easy-ish to sort but I have no idea where to start argghh!!! :confused:

    Thanks in advance


    Attached Files:

    Last edited: Apr 24, 2012
  2. drbeat

    drbeat New Member

    I managed to solve this...doh! I used the following thread from

    This comment in particular worked:


Share This Page