phpBB 3.2 and nginx configuration

Discussion in 'Server Operation' started by George321, Jan 24, 2017.

  1. George321

    George321 New Member

    Hello,
    i have ISPConfig 3.1.1p1 with Debian 8.
    My problem is that i can't install phpBB 3.2. I am trying to do a fresh install but while it loads fine the mydomain.com/install/app.php
    When i click the tab Install and redirects here: mydomain.com/install/app.php/install i take an ERROR 404 - Not Found!.
    So i asked in the official phpBB forums and they told me to do these https://github.com/phpbb/phpbb/blob/3.2.x/phpBB/docs/nginx.sample.conf
    nginx configurations. So i copied all these in Web Domain > Options > nginx Directives.
    But nothing happened still the same 404 error.
    What i must do to make it work?
    Link from my question in phpBB forum: https://www.phpbb.com/community/viewtopic.php?f=556&t=2405226&e=1&view=unread#unread
    Thanks.
     
  2. Hallia

    Hallia New Member

    Hi,

    I have the same problem you have but I'm not using ISPConfig but Ajenti V.
    I tried everything with this nginx.sample.conf file but I didn't know how to implement it well.
    Do you fix your issue?
     
  3. George321

    George321 New Member

    Hello this is the conf file i have in /etc/nginx/sites-enabled
    fiilename is: mydomainname.com.vhost
    and this is the conf: http://pastebin.com/Jxyb6A5A

    But it is for ISPConfig and not Ajenti V.
     
  4. Hallia

    Hallia New Member

    Thanks but still don't work.
    I think I will pass on ISPConfig with Apache 2 and bye bye errors ! ;)
     
  5. George321

    George321 New Member

    Ok good luck!
     
  6. ahrasis

    ahrasis Member

    Did you have any website that is properly working on your server?
     
  7. George321

    George321 New Member

    I tested the latest phpbb version and I think it is running OK.
     
    ahrasis likes this.
  8. ahrasis

    ahrasis Member

    Great. I thought the site is still not working.
     

Share This Page