phpadmin cant log in

Discussion in 'General' started by mphayesuk, Dec 27, 2006.

  1. mphayesuk

    mphayesuk Member

    Hi I am trying to log into the phpadmin tool using the portal. I have tried logging in as the global admin, site admin and web site user.. ie (admin) (user) and (web6_user) and all it comes back with is wrong username or password. I can log into the portal using any of these accounts and that works, but not when I try and log into phpadmin tool.

    All the accounts have got rights/options ticked to be able to use everything except for SSL, anon ftp, wap and ind error pages.

    Can anyone point me in the right direction.

    Thanks
     
  2. mphayesuk

    mphayesuk Member

    Update

    Ok one update I have logged in as the mysql root user... and that works fine...

    So how would a user login into phpadmin if they wanted to use/setup databases.

    Thanks
     
  3. mphayesuk

    mphayesuk Member

    ignore me perhaps in the future I will have a look through the manual.

    Thanks

    Dont mean anything by this.... I was reading the manual and found the answers.... you know us IT guys we dont read the manual until all alse fails.....
     
    Last edited: Dec 27, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont ignore you ;)

    After you created a website, you can add mysql databases on the options tab of the website. There you enter a password and ISPConfig displays you the database name and user. With this login information, your customers will be able to log into phpmyadmin.
     
  5. mphayesuk

    mphayesuk Member

    Great, got that working... now there is another problem.... this is what I have

    web4_user > www.domain1.com

    Creates a database

    web4_db2
    web4_u2 (with password)

    Now I want to import a text file 450MB... this cant be done through the phpadmin page, so I need to log into shell and run a command line to do this.

    If I log in as web4_user I cant see the database when I do >mysql and then select database();

    And I cant login as web4_us.... so what am I doing wrong. (I am using putty)

    Thanks
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Hi,

    it seems you mix up system and database users.

    1) Login with SSH with your sytem user.
    2) execute the mysql command with the parameters:

    mysql -u web4_u2 -p web4_db2

    and you are logged into the database. The password you are asked for is the database password.
     
  7. mphayesuk

    mphayesuk Member

    That works fine... excellent....

    If I wanted to import a file (text file 450MB) and I use the command line to do it, where would sql look for the file (default place) I read that it should be the home directory, so from ssh where would I put the file. Would you just ftp it to the directory you are in after logging in via ssh.

    Thanks
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The syntax to import a SQL file is:

    mysql -u web4_u2 -p web4_db2 < /path/to/yourfile.sql
     

Share This Page