PHP7

Discussion in 'Server Operation' started by SamTzu, May 11, 2016.

  1. SamTzu

    SamTzu Member HowtoForge Supporter

    Just a heads up...
    If you upgrade to PHP7 you are likely to run in to problems with MySQL.
    I got most of my problems to go away with these tricks.

    apt-get install php5-mysql
    Add extension=mysqli.so to php.ini
    Tags: Could not connect to MySQL, mysqli is missing, phpmyadmin doesn't work, Application Instantiation Error!, The mysqli|mysql extension is missing.
     
  2. sjau

    sjau Local Meanie Moderator

    try to install php-mysql
     
  3. SamTzu

    SamTzu Member HowtoForge Supporter

    It was all ready installed.
    Reason for the problems is that so much of PHP code is for v.5. Most are in the form php5-xxx and PHP7 dropped pretty much ALL support for backward compatibility.
     

Share This Page