[PHP7.2-FPM] Masked

Discussion in 'Server Operation' started by ewkilian, Nov 13, 2020.

Tags:
  1. ewkilian

    ewkilian Member

    Hi,
    I have Upgrade my Ubuntu 18, after Upgrade my PH7.2-PFPM is Down.
    Code:
    [email protected]:/etc/php/7.2# sudo service php7.2-fpm restart
    Failed to restart php7.2-fpm.service: Unit php7.2-fpm.service is masked.
    
    I have Try
    Code:
    sudo apt-get install --reinstall php7.2
    
    But I have the same problem.
    Have you a idea to help me to fix that.
    Thank you a lot
     
  2. ewkilian

    ewkilian Member

    You can see that :
    Code:
    [email protected]:/etc/php/7.2# sudo systemctl status php7.2-fpm
    ● php7.2-fpm.service
       Loaded: masked (/dev/null; bad)
       Active: inactive (dead)
    
    in additionnal when I run apt-get Update I see that :
    Code:
    [email protected]:/# sudo apt-get update
    Atteint :1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
    Atteint :2 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease
    Ign :3 https://packages.sury.org/php bionic InRelease
    Err :4 https://packages.sury.org/php bionic Release
      404  Not Found [IP : 104.31.95.169 443]
    Réception de :5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
    Lecture des listes de paquets... Fait
    E: Le dépôt https://packages.sury.org/php bionic Release n'a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
    
     
  3. ewkilian

    ewkilian Member

    I have Run :
    Code:
    [email protected]:/# sudo systemctl unmask php-fpm
    Unit php-fpm.service does not exist, proceeding anyway.
    [email protected]:/# sudo systemctl unmask php7.2-fpm
    Removed /etc/systemd/system/php7.2-fpm.service.
    [email protected]:/# sudo service php7.2-fpm restart
    
    But I have alway error 503 on my website
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Last edited: Nov 13, 2020
  5. ewkilian

    ewkilian Member

    Thank you, I think that on the first I must do that the apt-get update was successfull.

    I execute that ( https://packages.sury.org/php/README.txt )
    Code:
    ${SUDO} apt-get -y install apt-transport-https lsb-release ca-certificates curl
    ${SUDO} curl -sSL -o /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
    ${SUDO} sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
    ${SUDO} apt-get update
    But I have the same error with the apt-get update :
    Code:
    [email protected]:/# sudo apt-get update
    Atteint :1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
    Atteint :2 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease
    Ign :3 https://packages.sury.org/php bionic InRelease
    Err :4 https://packages.sury.org/php bionic Release
      404  Not Found [IP : 104.31.95.169 443]
    Réception de :5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
    Lecture des listes de paquets... Fait
    E: Le dépôt https://packages.sury.org/php bionic Release n'a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
    You can see the log :
    Apache2 access Log :
    Code:
    URL.com:443 62.102.228.178 - - [13/Nov/2020:13:19:46 +0100] "GET / HTTP/1.1" 503 5532 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0"
    Code:
    [email protected]:/var/log/apache2# sudo systemctl status php7.2-fpm
    ● php7.2-fpm.service - LSB: starts php7.2-fpm
       Loaded: loaded (/etc/init.d/php7.2-fpm; generated)
       Active: active (exited) since Fri 2020-11-13 11:19:39 CET; 2h 6min ago
         Docs: man:systemd-sysv-generator(8)
      Process: 1824 ExecStart=/etc/init.d/php7.2-fpm start (code=exited, status=0/SUCCESS)
    
    nov. 13 11:19:39 srvweb systemd[1]: Starting LSB: starts php7.2-fpm...
    nov. 13 11:19:39 srvweb systemd[1]: Started LSB: starts php7.2-fpm.
    
    Code:
    [email protected]:/var/log/apache2# sudo systemctl status mysql
    ● mysql.service - MySQL Community Server
       Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
       Active: active (running) since Fri 2020-11-13 11:19:40 CET; 2h 7min ago
      Process: 1654 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid (code=exited, status=0/SUCCESS)
      Process: 1370 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
     Main PID: 1663 (mysqld)
        Tasks: 36 (limit: 4915)
       CGroup: /system.slice/mysql.service
               └─1663 /usr/sbin/mysqld --daemonize --pid-file=/run/mysqld/mysqld.pid
    
    nov. 13 11:19:38 srvweb systemd[1]: Starting MySQL Community Server...
    nov. 13 11:19:40 srvweb systemd[1]: Started MySQL Community Server.
    
    where can I see other Logs ? to help to find the problem ?
    thank you a lot
     
  6. ewkilian

    ewkilian Member

    I see that Php7.2.... is Active: active (exited) and not Running
    I think this is the problem
     
  7. ewkilian

    ewkilian Member

    Code:
    [email protected]:/var/log/apache2# sudo a2enmod php7.2
    Considering dependency mpm_prefork for php7.2:
    Considering conflict mpm_event for mpm_prefork:
    Considering conflict mpm_worker for mpm_prefork:
    Module mpm_prefork already enabled
    Considering conflict php5 for php7.2:
    Module php7.2 already enabled
    [email protected]:/var/log/apache2#
    Code:
    [email protected]:/var/log/apache2# sudo apache2ctl -t
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    Syntax OK
    
    I must upgrade ISPCONFIG ?
     
  8. ewkilian

    ewkilian Member

    When i try update ISPCONFIG
    I see that :
    Code:
    Operating System: Ubuntu 18.04.5 LTS (Bionic Beaver)
    
    PHP Multibyte Module (MB) is missing.
    
    I must reinstall all php package. how ? because I can execute apt-get update :( (because a problem with php repository
     
  9. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Code:
    Err :4 https://packages.sury.org/php bionic Release
    You are running Ubuntu. packages.sury.org is for Debian packages, that is why your Ubuntu can not find packages to install.
    Check the repo for ubuntu PHP packages: https://deb.sury.org/
     
    ewkilian likes this.
  10. ewkilian

    ewkilian Member

    Thank you Taleman for your BIG HELP !
    I dont know that this package was for Debian.
    Thank you a lot !
     

Share This Page