Php5

Discussion in 'Installation/Configuration' started by drum, Oct 27, 2006.

  1. drum

    drum New Member

    Okay, I've installed PHP5 on my ISPConfig box, and it is working fine as at the command line, however the webserver is still using 4.xx, I'm guessing I've missed a config or something in apache, any pointers would be most appreciated.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You must install the mod_php5 from your linux distribution and not only the commandline php5.
     
  3. drum

    drum New Member

    Do you mean libapache-mod-php5?? (I'm using debian BTW)

    If so I already have it installed.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have libapache-mod-php5 installed, your webserver shall run under php5. Please check if the php5 module is listed in the mods-enabled directory in the apache configuration directory.
     
  5. drum

    drum New Member

    I must have done something wrong, as it not in either mods-enabled or mods-available
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    apt-get install libapache-mod-php5
    again.
     
  7. drum

    drum New Member

    I get
    Code:
    Reading Package Lists... Done
    Building Dependency Tree... Done
    libapache-mod-php5 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/apache2/mods-available
    and
    Code:
    ls -la /etc/apache2/mods-enabled
    ?
     

Share This Page