PHP5 + Zend optimizer problem

Discussion in 'Installation/Configuration' started by thim, Oct 27, 2006.

  1. thim

    thim New Member

    We want to secure our php script using Zend Encoder.
    There for we need to install Zend Optimizer on our Centos Server.

    I followed an zend tutorial howto, but no success.

    It kept complaining something about

    Failed loading /usr/local/Zend/lib/Optimizer-3.0.2/php-5.0.x/
    +/usr/local/Zend/lib/Optimizer-3.0.2/php-5.0.x/ undefined
    +symbol: match

    Is there anybody who got it working on a Centos 4.4 with apache 2 and PHP5 (installed through yum via centosplus repo)

    Any help or pointers are welcome.
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you download the Zend Optimizer directly from There's an nistaller in the package, you should run it to install the Zend Optimizer.

    What's the output of
    uname -m
  3. thim

    thim New Member

    I did use Zend Optimizer from the zend website itself.

    Version 3.02 .

    I will try it again tomorrow and will report you the output of

    uname -m
  4. falko

    falko Super Moderator ISPConfig Developer

    And did you use the installer?
  5. thim

    thim New Member

    Yes i did use the installer.
  6. thim

    thim New Member

    Ok I fixed it.

    The problem lies in the 3.02 version of zend optimizer. This version is not compatible with Centos 4.4 (PHP5) (maybe also others distro's).

    I took the 3.01 version, followed the installer. And everything just went fine.

    The Zend Optimizer is working perfect now.

Share This Page