PHP5 Problem

Discussion in 'Installation/Configuration' started by msource, Dec 6, 2007.

  1. msource

    msource New Member


    Hi have my ISPConfig box good configured.
    I passe a portal in joomla v1.0.13 from a sever with VHCS + PHP4/MySQL4 to my new machine with ISPConfig + PHP5/MySQL5.

    The Data from the Database are all correct, but i have one little problem.
    In the configuration file from joomla i have this ex:
    $mosConfig_error_message 'Este site encontra-se temporáriamente indisponível.<br /> Por favor, avise o Administrador de Sistema';
    The word's temporáriamente and indisponível appears with an ? on the portal. And this is appening with the lang file to.

    I notice that if i put the text ex: tempor&aacute;riamente or indispon&iacute;vel it appears well with out the ? on the letter.

    Is there anything that i have to configure in ISPConfig or PHP5 for read correctly from the file the word's?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. msource

    msource New Member


    I change the AddDefaultCharset to
    AddDefaultCharset ISO-8859-1
    , but the site is worst.

    You can see in this ScreenShot

    The letter's are all wrong. There are a diference bettween the Old PHP4 conf and the new PHP5 conf.

    On old server with PHP4 [PHPINFO], we can see that in section HTTP Headers Information, the Content-Type is just text/html

    On the new server with PHP5 [PHPINFO], we can see that in section HTTP Headers Information, the Content-Type is just text/html; charset=ISO-8859-1.

    The colation in the MYSQL is OK, is latin_swidish_ci, and this option with AddDefaultCharset disable appears ok.

    I dont understand why this is wrong. Could someone please help me?
  4. msource

    msource New Member


    Sorry for all the efford that i cause.
    I resolve this problem, just by edit the
    and comment out the UTF-8

    Then when restore the databeses into the MySQL, i import it with utf-8 and all whent ok.

    Tanks a lot for all the efford. Sorry for all the troble.

Share This Page