php5 /mysql

Discussion in 'Installation/Configuration' started by user70, Jul 30, 2009.

  1. user70

    user70 New Member

    hi,

    I change my system from ubuntu 8.04 to 8.10, after that i have this messsage.
    and i don't know how i can resolve it.. thanks for your help.

    "PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/msql.so' - /usr/lib/php5/20060613+lfs/msql.so: cannot open shared object file: No such file or directory in Unknown on line 0

    PHP Warning: Module 'imap' already loaded in Unknown on line 0
    PHP 5.2.6-2ubuntu4.2 with Suhosin-Patch 0.9.6.2 (cli) (built: Apr 17 2009 14:44:11)"

    I have mysql.so but no msql.so in /usr/lib/php5/20060613+lfs/ ???

    -rw-r--r-- 1 root root 105200 2009-04-17 16:50 gd.so
    -rw-r--r-- 1 root root 93488 2008-08-21 04:30 imap.so
    -rw-r--r-- 1 root root 101604 2009-04-17 16:50 mysqli.so
    -rw-r--r-- 1 root root 44604 2009-04-17 16:50 mysql.so
    -rw-r--r-- 1 root root 26436 2009-04-17 16:50 pdo_mysql.so
    -rw-r--r-- 1 root root 89728 2009-04-17 16:50 pdo.so
    -rw-r--r-- 1 root root 26664 2009-04-17 16:50 snmp.so
     
  2. user70

    user70 New Member

    how can i solved this ?

    # dpkg -s php5-mysql
    Package: php5-mysql
    Status: install ok installed
    Priority: optional
    Section: web
    Installed-Size: 240
    Maintainer: Ubuntu Core Developers <[email protected]>
    Architecture: i386
    Source: php5
    Version: 5.2.6-2ubuntu4.2
    Replaces: php5-mysqli
    Depends: libc6 (>= 2.4), libmysqlclient15off (>= 5.0.27-1), phpapi-20060613+lfs, php5-common (= 5.2.6-2ubuntu4.2)
    Conflicts: php5-mysqli
    Conffiles:
    /etc/php5/conf.d/mysql.ini d6b592dc2eb7a2e3ff433d2506840fa6
    /etc/php5/conf.d/mysqli.ini 932898ab2524dd4cf27055652e1b4278
    /etc/php5/conf.d/pdo_mysql.ini ed37ffe9d4a777fc7abb5c54720723f9
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/apt/sources.list?
     
  4. user70

    user70 New Member

    THis is my /etc/apt/soucres.list

    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid main restricted
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid main restricted
    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
    deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
    deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted

    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid universe
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid universe
    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates universe
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates universe
    deb http://security.ubuntu.com/ubuntu intrepid-security universe
    deb-src http://security.ubuntu.com/ubuntu intrepid-security universe

    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid multiverse
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid multiverse
    deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
    deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
    deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
    deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Looks ok.

    What's the output of
    Code:
    ls -l /etc/php5/conf.d/
    ?
     

Share This Page