PHP5 + libssh2 problem

Discussion in 'Installation/Configuration' started by thim, Oct 27, 2006.

  1. thim

    thim New Member

    I want to install Libssh2 so i can use the ssh exec via PHP as a certain user.

    I have an Centos 4.4 running.

    I followed the tutorial on PHP.NET but i had no succes.
    I couldn't even compile. Everything was ok during the configure but during the MAKE I always get following error

    Code:
    gcc: /usr/include: linker input file unused because linking not done
    channel.c:1253:10: /usr/include: No such file or directory
    channel.c:71: internal compiler error: Segmentation fault
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
    ...

    Next I try to installe an RPM from the DAG repo again no succes.

    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library
    '/usr/lib/php/modules/ssh2.so' - /usr/lib/php/modules/ssh2.so: undefined
    symbol: zend_hash_add_or_update in Unknown on line 0

    Is there anybody who got it working on a Centos 4.4 with apache 2 and PHP5 (installed through yum via centosplus repo)

    Any help or pointers are welcome.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Segmentation faults may be caused by hardware problems as well as software problems. Please check your hardware with e.g. memcheck that can be startde from the boot disk of most linux distributions.
     
  3. thim

    thim New Member

    I fixed it.

    I had compiled a php from source. And installed it afterwards i installed a php 5 through yum and removed the source php. But i forget a few things. This gave some errors in pear and so ... Also by installing the libssh2.

    So i removed everything of the old PHP and tried again.

    SSH2 works perfect now.

    Thnx for the reply till
     
  4. thim

    thim New Member

    Another problem

    There is no libssh2 aviable for x86_64!

    Who knows were to get this libssh2 for x86_64?

    I tried to compile it from source but it kept complaining about missing libcrypto but i can't seem to get it installed.

    Who can help me with the libcrypto or libssh2 for Centos 4.4 64BIT ?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you search for these packages with
    Code:
    yum search ssh
    or
    Code:
    yum search crypto
    ?
     
  6. thim

    thim New Member

    We fixed it again.

    We had a closer look at the configure file of libssh2. It seemed that there was an option to change the openssl path with --with-opensll=/usr/

    this did the trick

    Thnx again for your reply :)
     

Share This Page