php5-imagick error on Ubuntu 8.04.2

Discussion in 'General' started by wr19026, Apr 22, 2009.

  1. wr19026

    wr19026 New Member

    I'm a victim of the "PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/' - cannot open shared object file: No such file or directory in Unknown on line 0" error.

    Seems that Canonical does not have a working fix in place for this (this is happening on a fully updated server). The machine this appears on was upgraded from 6.10 via 7.04 and 7.10 to 8.04

    Question: would installing libmagick10 solve it or would this ( be a better solution without breaking my ISPconfig installation (or any of the associated software)

    Upgrading to 8.10 etc is not something I'd want to do as I chose 8.04 to have a server that requires very little (if any) attention and is supported beyond the economic life of the hardware.
  2. tebokkel

    tebokkel New Member

    Well.. with ISPConfig 2 the case is that you can reconfigure/change/upgrade "almost" everything in you base system without the risk of breaking ISPConfig (as long as you keep using the same programs for Web, mail, FTP and such). Libraries are almost irrelevant for ISPConfig itself.

    I would surely try to get it working by removing/reinstalling PHP and Imagemagick; you can hardly be worse off than now.. :)

  3. wr19026

    wr19026 New Member

    I can't uninstall php - there is a (working) webshop running that is using PHP.

    It doesn't seem to cause a lot of issues from a user perspective though, only an error log that is booming and an e-mail box for the admin user that is getting the warning message every 5 minutes

    Still, I'd like to know if installing imagick10 or the other solution I found on the web would solve this.
  4. tebokkel

    tebokkel New Member

  5. wr19026

    wr19026 New Member

    Nope, already tried it (and retried it to be sure) and it still doesn't help

Share This Page