php4mod with php5-cgi+suphp with ISPConfig

Discussion in 'Installation/Configuration' started by Hans, May 29, 2007.

  1. Hans

    Hans Moderator ISPConfig Developer

    On the moment, i've a Debian Etch server with php5-cgi and suPHP enabled.
    php5 and suPHP has been setup according: http://www.howtoforge.com/suphp_debian_etch_ispconfig

    For the sites which are not allowed to use the php5-cgi with the suphp-mechanism, i use php5 as a module as well. For that sites i've put some extra directives within the directives field within ISPConfig, like these:


    suPHP_Engine off
    RemoveHandler .php
    php_admin_flag engine on



    This works fine, however for compatible reasons, i need to use php4 as a module in stead of php5.

    My question is:
    Which steps do i have to take to use php4 as a module with php5-cgi+suPHP in stead of php5 as a module with php5-cgi+suPHP ?

    Thanks in advance.
     
  2. Hans

    Hans Moderator ISPConfig Developer

    I found the solution

    First i disabled php5 as a module with:
    a2dismod php5

    Then i enabled php4 as a module with:
    a2enmod php4

    I changed the Apache directives field within ISPConfig for the website into:

    suPHP_Engine off
    RemoveHandler .php5
    php_admin_flag engine on

    I installed libapache2-mod-php4 with:

    apt-get install libapache2-mod-php4
    (libapache2-mod-php5 will be removed and Apache2 will reload automaticly)

    That's it. :)
     
    Last edited: May 30, 2007

Share This Page