PHP4 and PHP5 for SUSE 9.3 Prof

Discussion in 'Installation/Configuration' started by M.Behrens, Apr 1, 2006.

  1. M.Behrens

    M.Behrens New Member


    Now I have a new Problem. :(

    I want to use PHP4 and PHP5 on my Server, because I want to install OSCommerce and that need PHP4.

    My Server is installed with SUSE9.3 Prof and ISPConfig (I use the HowTo).

    Have anyone a HowTo to install PHP4 too when the Apache is now working with only PHP5?

    I hope anyone can help me! :eek:

    I found the following HowTo in this Forum
    I hope somebody can tell me that specify.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can follow the thread that you posted above.

    Generally the easiest way is to install php4 as cgi and then add the directives nescessary for using the php4 cgi version in the apache directives field of ISPConfig.

    You may also have a look at this howto:
  3. M.Behrens

    M.Behrens New Member

    Thanks Till!

    Can I follow the HowTo when I have SUSE with apt-get?

    But if I understand that correctly, all Skripte those must be supposed to then run under PHP4 the ending .php4 possess.
    That lasts with OSCommerce a large expenditure to change. Or is there a simple way?

    If I would change the complete php from 5 to 4, then still does everything run with ISPConfig, or does give it then to difficulties? I had that here correctly understood in this HowTo (please read the last post of this thread).

    Thank You!
  4. falko

    falko Super Moderator ISPConfig Developer

    Forget about the apt-get parts in that tutorial and concentrate on the Apache configuration in that tutorial.

    You could run PHP5 as CGI instead and use .php5 for PHP5 scripts (e.g. with

    AddHandler php-script .php5
    Action php-script /cgi-bin/php5
    ); scripts with the extension .php would then be run by PHP4.

    No, it doesn't cause problems with ISPConfig.

Share This Page