Php

Discussion in 'General' started by alexillsley, Dec 22, 2006.

  1. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Not unless ISPConfig created it, the servers name is: server1 and the servers alias is: server1.fireproductions.co.uk

    I hope that we can get to to the end of this,
    thanks,
    Alex
     
    Last edited: Dec 26, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig doesn't do something like that.

    I think in order to solve this issue we need to see your whole Apache configuration...
     
  3. daveb

    daveb Member

    i am very green with linux just started using 2 weeks ago. but if it would help since iam having same issue w/suse10.2 i can post my apache config too if you tell me which file your lookin for, like "/etc/apache2/httpd.conf ?" or something different.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Plaese read the complete thread and try out every solution that is posted here. The issue from alexillsley is very special and most likely you dont have the exact same problem.
     
  5. daveb

    daveb Member

    actually i do belive it is the same problem that he is having. i can veiw only php3 files in my webs i created. php php4 5 etc. dont work, only sends the file to me in a text form. but the ispconfig, squirrelmail, phpmyadmin, all use .php files and work fine. its only in my webs i create that has this problem.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig comes with its own web server (on port 81), so it isn't affected by any problems you have with your main Apache (on port 80).
     
  7. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    I think in order to solve this issue we need to see your whole Apache configuration...

    So what do you want me to post? do you want access to my server?
    Thanks,
    Alex
     
  8. doc

    doc New Member

    Same problem here looking into it now
     
  9. doc

    doc New Member

    Don't know if this is the problem, but php is working on my system again. Didn't try switching off php in ispconfig yet

    host:/etc/apache2/conf.d # cat php5.conf
    <IfModule mod_php5.c>
    AddHandler application/x-httpd-php .php4
    AddHandler application/x-httpd-php .php5
    AddHandler application/x-httpd-php .php
    AddHandler application/x-httpd-php-source .php4s
    AddHandler application/x-httpd-php-source .php5s
    AddHandler application/x-httpd-php-source .phps
    DirectoryIndex index.php4
    DirectoryIndex index.php5
    DirectoryIndex index.php
    </IfModule>

    seems to be correct, in my php5.conf it was changed to:

    host:/etc/apache2/conf.d # cat php5.conf.old
    <IfModule mod_php5.c>
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php4
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php5
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .php4s
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .php5s
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .phps
    DirectoryIndex index.php4
    DirectoryIndex index.php5
    DirectoryIndex index.php
    </IfModule>
    host:/etc/apache2/conf.d #

    Thus by removing the ##ISPConfig INSTALL## part it worked again :)
     
  10. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    looks like lots of people are having this problem:eek:
    doc hope this will fix it!! isp config seems to have added in that line
    Thanks
     
    Last edited: Dec 29, 2006
  11. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    YAY YAY YAY:) THANKS DOC!!!!!! IT WORKS!!!! Thanks eveyone else aswell
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Removing these comments disables the abilitity of ISPConfig to enable / disable php, so its not the solution for your problem.

    But I got another idea, are your php pages located in the website directories that ISPConfig created for you and did you access the pages trough the correct domain of this special website and not trough the IP plus a path of the website?
     

Share This Page