php woes

Discussion in 'Installation/Configuration' started by rmarini, Aug 5, 2006.

  1. rmarini

    rmarini New Member


    First - let me say that the perfect set up tutorials are awesome. I used the ubuntu one and it worked flawlessly for building a dev box in my home. Recently, however, I purchased a new dedicated server (debian) and followed the same guide to configure it. Everything seems to be working EXCEPT for php4. When I attempt to view a file containing phpinfo() (and i guess the same would be true for anything with a .php extension) such as I am asked to download something which is application/x-httpd-php. Any ideas on how I can resolve this?

    Perhaps related to this is the fact that I could not install php4-imap - it returned an error that it required a package called phpapi but said package was not available.

    My sources list is as follows

    # Main
    deb php5 sarge
    deb stable main non-free contrib
    deb stable/non-US main contrib non-free
    deb sarge-backports main contrib non-free
    deb php5 sarge
    deb-src php5 sarge
    deb stable all
    deb-src stable all
    # Source
    deb-src stable main non-free contrib
    deb-src stable/non-US main contrib non-free
    # Security
    deb stable/updates main contrib non-free
    deb unstable main non-free contrib
  2. rmarini

    rmarini New Member

    Well, I was able to get it working by purging the apt cache. Is there any known issue with php4-imap though? I still get errors on attempting to install it.
  3. falko

    falko Super Moderator ISPConfig Developer

  4. rmarini

    rmarini New Member

    I did :-D I meant that I had used the ubuntu tutorial flawlessly on a system prior to this one.
  5. falko

    falko Super Moderator ISPConfig Developer

    Ok, then you most likely did something wrong. I never had problems with that tutorial...

Share This Page