PHP without sqlite?

Discussion in 'Installation/Configuration' started by crypted, Nov 3, 2008.

  1. crypted

    crypted New Member

    I'm having issues with Roundcube after an upgrade of both ISPConfig and Roundcube. After trying to get help from Roundcube's website, it seems PHP doesn't have SQLITE support any longer by default from ISPConfig's installation process?

    System 	Linux 2.6.18-92.1.13.el5 #1 SMP Wed Sep 24 19:33:52 EDT 2008 i686
    Build Date 	Jul 16 2008 19:54:37
    Configure Command 	'./configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/usr/share/file/magic.mime' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'
    additional .ini files parsed 	/etc/php.d/dbase.ini, /etc/php.d/dom.ini, /etc/php.d/gd.ini, /etc/php.d/imap.ini, /etc/php.d/ldap.ini, /etc/php.d/mysql.ini, /etc/php.d/mysqli.ini, /etc/php.d/odbc.ini, /etc/php.d/pdo.ini, /etc/php.d/pdo_mysql.ini, /etc/php.d/pdo_odbc.ini, /etc/php.d/pdo_sqlite.ini, /etc/php.d/xmlreader.ini, /etc/php.d/xmlrpc.ini, /etc/php.d/xmlwriter.ini, /etc/php.d/xsl.ini
    PDO support	enabled
    PDO drivers 	mysql, odbc, sqlite
    PDO Driver for SQLite 3.x	enabled
    PECL Module version 	1.0.1 $Id: pdo_sqlite.c,v 2006/01/01 12:50:12 sniper Exp $
    SQLite Library 	3.3.6
    The top says '--without-sqlite' in the configuration but it says sqlite in other places so I'm not sure what to think...

    /etc/php.d/pdo_sqlite.ini has the following:

    ; Enable pdo_sqlite extension module
    How can I get SQLITE working properly?


    Unable to connect to the database!
    Please contact your server-administrator
    DB Error in /var/www/web104/web/program/include/ (105): DB Error: extension not found
  2. falko

    falko Super Moderator ISPConfig Developer

    We don't disable SQLite, but you can take a look at the PHP configure statement in install_ispconfig/compile_aps/compile.
  3. crypted

    crypted New Member

    well this certainly is weird, i can't figure out why it won't work. oh well.
  4. falko

    falko Super Moderator ISPConfig Developer

    Maybe SQLite needs to be explicitly enabled in the configure string? You can download the PHP5 sources, untar them and run
    ./configure --help
    in the source directory to find out about all available options.

Share This Page