PHP vulnerabilities - should we be worried, is there an upgrade path ?

Discussion in 'General' started by winsbury, Sep 11, 2019.

  1. winsbury

    winsbury New Member

    Last edited: Sep 11, 2019
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Not directly related to ISPConfig as the PHP on your server is not from ISPConfig. Install updates of your operating system as usual and ensure that your operating system version is within the supported version range of the Linux distribution so that you get still updates. And be aware that Linux distributions patch security issues in programs without setting a higher version number of the application, so you can't see from the version number of e.g. php --version if your php is vulnerable or not, you have to look at the php distribution pages and package trackers of the distributor to see if the currently installed package version is patched or not. Ubuntu 18.04 is still fully supported by canonical, so all you have to do is to install updates regularly with

    apt-get update
    apt-get upgrade

    that's all.

    I moved your post to the general forum as it's not ispconfig development related.
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  4. winsbury

    winsbury New Member

    well that's okay then , thanks guys.
     

Share This Page