PHP Versions per site, is it possible to have PHP Version for an application

Discussion in 'General' started by Nap, Jul 30, 2014.

  1. Nap

    Nap Member

    Allowing each site to choose the version of PHP they require is a nice feature.
    I'm wondering if it's possible to extend this so that a particular application (phpBB2 in my case) makes use of specific PHP version, while the rest of the site works using the global setting?

    Having upgraded my U10.04LTS server to U14.04LTS, I've found that my forum has stopped working. I'm happy with the newer versions of the LAMP stack and am seeking a way to get my phpBB2 forum running somehow.

  2. neutrino

    neutrino Member

    Upgrading your phpbb forum seems quite a good idea.

    But, if that's not possible, you can put your forum on a dedicated site, stacking it up with your main site isn't a good practice.
  3. Nap

    Nap Member

    thnx neutrino, that's exactly what I'm thinking of doing. I thought I would ask beforehand.

    Hopefully an upgrade will work as it's phpBB2 with the Categories Hierarchy mod, and I have a feeling I might not be able to upgrade it, but I'll see soon enough. Going to check with phpBBrefugees now.
  4. Nap

    Nap Member

    thnx neutrino.

    I asked, on the phpBB3 site, for advice on how to migrate my phpBB2 with Categories Hierarchy mod. They suggested I flatten my forum first and then try migrating. Which I did, and it worked. I did need to configure a bunch of things after the migration, but the forum is intact.


Share This Page