PHP versions on ispconfig

Discussion in 'Installation/Configuration' started by Frédéric URBANIAK, Nov 9, 2020.

  1. Frédéric URBANIAK

    Frédéric URBANIAK New Member

    I'm sorry but i'm not an expert and i have'nt really understand how to change php version
    I have a debian 9 with ispconfig. I've juste upgraded my os and ispconfig to 3.2
    I've installed new version PHP 7.4 and when i verfiy with command "php -v" in my shell it's ok
    Can i activate PHP 7.4 as default for ispconfig and all sites?
    Or propose all différents versions for all sites?
    Sorry if my english is bad, i'm little french who is not very friendly with the language of Shakespeare :)
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ISPConfig is supported on an OS with the PHP version that comes as default with that OS. Changing the OS default PHP to something else makes ISPConfig not work.
    Depending on how you did the PHP upgrade, using these commands may get your system back:
    Code:
    update-alternatives --config php
    update-alternatives --config php-cgi
    If you need some other PHP version for some websites, this is the way to do it:
    https://www.howtoforge.com/tutorial...bian-default-php-back-to-the-original-version
     
    ahrasis likes this.
  3. Frédéric URBANIAK

    Frédéric URBANIAK New Member

    Tks for this explication :)

    But i hope that i have break link to roundcube :(
    when i type mysite.com/webmail i've error 404 o_O
    it's probably when i have shoot php 7.0 oups !
    so i you have the tip to replace it in function :D
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What is shown on your system when you run the two update-alternatives -commands?
     

Share This Page