PHP -V errors

Discussion in 'Installation/Configuration' started by vaio, Jan 22, 2013.

  1. vaio

    vaio New Member

    Hello ISP friends!
    When typing:
    Code:
    s1:~# php -v
    I get output:
    Code:
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imagick.ini on line 1 in Unknown on line 0
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.3.so:  /usr/local/ioncube/ioncube_loader_lin_5.3.so: wrong ELF class: ELFCLASS32
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/imagick.so' - /usr/lib/php5/20090626/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/memcache.so' - /usr/lib/php5/20090626/memcache.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.3.3-7+squeeze14 with Suhosin-Patch (cli) (built: Aug  6 2012 14:18:06)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
        with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
    I would really appreciate if someone can explain what exactly is here problem and why this happened?

    Much appreciated!
    V.
     
  2. till

    till Super Moderator

    Seems as if some loadable php modules are missing and that php was updated without installing a new ioncube loader. You should reinstall the php modules mentioned in the error message and install a new ioncube loader.
     

Share This Page