Php upgrade issue

Discussion in 'Server Operation' started by leonep, Jun 27, 2014.

  1. leonep

    leonep New Member

    Hi all
    I have a perfect installation of centos 6.4 ispconfig 3

    after upgrade at php 5.4.30 the websistes under /var/www/html stop working in http but in https continue normally work! i see the output text only on browser like this:

    | +-------------------------------------------------------------------------+ */ // include environment require_once 'program/include/iniset.php'; // init application, start session, init output class, etc. $RCMAIL = rcmail::get_instance(); // Make the whole PHP output non-cacheable (#1487797) $RCMAIL->output->nocacheing_headers(); // turn on output buffering ob_start(); // check if config files had errors if ($err_str = $RCMAIL->config->get_error()) { rcmail::raise_error(array( 'code' => 601, 'type' => 'php', 'message' => $err_str), false, true); } // check DB connections and exit on failure if ($err_str = $RCMAIL->db->is_error()) { rcmail::raise_error(array( 'code' => 603, 'type' => 'db', 'message' => $err_str), FALSE, TRUE); } // error steps if ($RCMAIL->action == 'error' && !empty($_GET['_code'])) { rcmail::raise_error(array('code' => hexdec($_GET['_code'])), FALSE, TRUE); } // check if https is required (for login) and redirect if necessary if (empty($_SESSION['user_id']) && ($force_https = $RCMAIL->config->get('force_https', false))) { $https_port = is_bool($force_https) ? 443 : $force_https; if (!rcube_utils::https_che

    take a look here :

    the other websites in ispconfig work normally

    i have used yum for upgrade php with remo reposity

    also i found this error in httpd error log
    mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/ on line 14990

    thank you for help !!!!!!!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    enable short_open_tag in php.ini and restart apache.
  3. leonep

    leonep New Member

    thanks till but nothing happen after
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that apache mod_php is installed and enabled.
  5. leonep

    leonep New Member

    modules in folder are:

    [[email protected] httpd]# cd modules/
    [[email protected] modules]# ls

    and this is my php.con file located under /etc/httpd/conf.d

    # PHP is an HTML-embedded scripting language which attempts to make it
    # easy for developers to write dynamically generated webpages.
    <IfModule prefork.c>
    LoadModule php5_module modules/
    <IfModule !prefork.c>
    LoadModule php5_module modules/

    # Cause the PHP interpreter to handle files with a .php extension.
    <FilesMatch \.php$>
    SetHandler application/x-httpd-php

    # Allow php to handle Multiviews
    AddType text/html .php

    # Add index.php to the list of files that will be served as directory
    # indexes.
    DirectoryIndex index.php

    # Uncomment the following lines to allow PHP to pretty-print .phps
    # files as PHP source code:
    #<FilesMatch \.phps$>
    # SetHandler application/x-httpd-php-source

    # Apache specific PHP configuration options
    # those can be override in each configured vhost
    php_value session.save_handler "files"
    php_value session.save_path "/var/lib/php/session"

    there is a command to check status of mod_php?
    it is possible also a workaround executing php with fastcgi like sites under ispconfig?

  6. leonep

    leonep New Member

    i have do this command for check modules

    apachectl -t -D DUMP_MODULES

    Loaded Modules:
    core_module (static)
    mpm_prefork_module (static)
    http_module (static)
    so_module (static)
    auth_basic_module (shared)
    auth_digest_module (shared)
    authn_file_module (shared)
    authn_alias_module (shared)
    authn_anon_module (shared)
    authn_dbm_module (shared)
    authn_default_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    authz_owner_module (shared)
    authz_groupfile_module (shared)
    authz_dbm_module (shared)
    authz_default_module (shared)
    ldap_module (shared)
    authnz_ldap_module (shared)
    include_module (shared)
    log_config_module (shared)
    logio_module (shared)
    env_module (shared)
    ext_filter_module (shared)
    mime_magic_module (shared)
    expires_module (shared)
    deflate_module (shared)
    headers_module (shared)
    usertrack_module (shared)
    setenvif_module (shared)
    mime_module (shared)
    dav_module (shared)
    status_module (shared)
    autoindex_module (shared)
    info_module (shared)
    dav_fs_module (shared)
    vhost_alias_module (shared)
    negotiation_module (shared)
    dir_module (shared)
    actions_module (shared)
    speling_module (shared)
    userdir_module (shared)
    alias_module (shared)
    substitute_module (shared)
    rewrite_module (shared)
    proxy_module (shared)
    proxy_balancer_module (shared)
    proxy_ftp_module (shared)
    proxy_http_module (shared)
    proxy_ajp_module (shared)
    proxy_connect_module (shared)
    cache_module (shared)
    suexec_module (shared)
    disk_cache_module (shared)
    cgi_module (shared)
    version_module (shared)
    fcgid_module (shared)
    php5_module (shared)
    python_module (shared)
    ruby_module (shared)
    ssl_module (shared)
    suphp_module (shared)
  7. leonep

    leonep New Member

    i come back to php 5.3.3 . this solve the problem but now i have the initial problem . i need to upgrade php.what is the correct way ? thanks
  8. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page