PHP Upgrade In ISPConfig got Problem

Discussion in 'General' started by asgare, Jan 2, 2019.

  1. asgare

    asgare Member

    I am very sorry if my simple questions annoying you. Really sorry for that.

    My Debian version:
    Code:
    [email protected]:/# cat /etc/*-release
    PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
    NAME="Debian GNU/Linux"
    VERSION_ID="9"
    VERSION="9 (stretch)"
    ID=debian
    HOME_URL="https://www.debian.org/"
    SUPPORT_URL="https://www.debian.org/support"
    BUG_REPORT_URL="https://bugs.debian.org/"
    
    Results of mention command:
    Code:
    [email protected]:/# dpkg --list | grep -i x2go
    ii  libnx-x11-6:amd64                 2:3.5.99.16-1.0x2go1+git20180719.2988+9.main.1 amd64        nxagent's libNX_X11 client-part library
    ii  libx2go-log-perl                  4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          Perl X2Go::Log package
    ii  libx2go-server-db-perl            4.1.0.2-0x2go1+git20180801.1642+9.main.1       amd64        Perl X2Go::Server:DB package
    ii  libx2go-server-perl               4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          Perl X2Go::Server package
    ii  libxcomp3:amd64                   2:3.5.99.16-1.0x2go1+git20180719.2988+9.main.1 amd64        NX compression library
    ii  libxcompshad3:amd64               2:3.5.99.16-1.0x2go1+git20180719.2988+9.main.1 amd64        NX shadowing library
    ii  nx-x11-common                     2:3.5.99.16-1.0x2go1+git20180719.2988+9.main.1 all          nx-X11 (common files)
    ii  nxagent                           2:3.5.99.16-1.0x2go1+git20180719.2988+9.main.1 amd64        Nested Xserver (aka NX Agent) supporting the NX compression protocol
    ii  x2goserver                        4.1.0.2-0x2go1+git20180801.1642+9.main.1       amd64        X2Go server
    ii  x2goserver-common                 4.1.0.2-0x2go1+git20180801.1642+9.main.1       amd64        X2Go Server (common files)
    ii  x2goserver-extensions             4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          X2Go Server (extension support)
    ii  x2goserver-fmbindings             4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          X2Go Server (file manager bindings)
    ii  x2goserver-printing               4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          X2Go server (printing support)
    ii  x2goserver-x2goagent              4.1.0.2-0x2go1+git20180801.1642+9.main.1       amd64        X2Go Server's X2Go Agent
    ii  x2goserver-xsession               4.1.0.2-0x2go1+git20180801.1642+9.main.1       all          X2Go Server (Xsession runner)
    
    and this one:
    Code:
    [email protected]:/# dpkg --search /usr/lib/x2go/libx2go-server-db-sqlite3-wrapper
    libx2go-server-db-perl: /usr/lib/x2go/libx2go-server-db-sqlite3-wrapper
    
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    So the problem package is
    Code:
    libx2go-server-db-perl
    That is not installed in ordinary ISPConfig installations. If you do not need it, purge it away. Or configure it properly so that error goes away.
    By the way, my Debian 9.6 does not have package libx2go-server-db-perl available. Where was it installed from?
     
  3. Jesse Norell

    Jesse Norell Well-Known Member

    There is probably way to reset the statoverride, though I don't know how off the top of my head; as a workaround, you could probably create x2gouser group and see if dpkg continues, then ensure that group is removed after you purge your x2go packages, if you are doing that.
     
  4. asgare

    asgare Member

    Finally, problem solved!
    Thanks for everyone who had contributed to this issue and thanks to till for making this place for people like us.

    After using that long command (./configure ...) for hundreds of times and solving each issue that comes to me it solved. Unfortunately, I don't remember how many packages installed, reinstalled or updated but it worked for me.
    I don't know if there is a command to list my history here to share with contributors and friends.

    Thanks and Love
    Asghar
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You can see in /var/log/dpkg.log what packages were installed or removed. And terminal may have lines stored when you scroll up, and there is command history that shows what is in history buffer.
     
  6. asgare

    asgare Member

    I picked up all necessary logs for the last day configuration. Please check out the attachment. Even I didn't figure out how could I did that.
     

    Attached Files:

Share This Page