PHP Support

Discussion in 'Installation/Configuration' started by ChildOTK, Feb 27, 2007.

  1. ChildOTK

    ChildOTK New Member

    Hi all,

    I have a slight problem,

    I have just installed ISPConfig, and install process has run fine, although it did not install my db properly, I fixed that by importing the db_ispconfig.sql file manually, so thats all fine....

    Problem number 1, when I go to Management -> Server -> Settings, and I try to setup a server, it never keeps my settings, it just goes back to nothing, and no server actually gets set.

    Problem number 2, my postfix email that was being recieved for my system did not work anymore, but I fixed that by editing the /etc/postfix/my.cnf file and under the 'mydestination' setting added the $myhostname option, that works again, phew! Problem is now that when I try and access my presetup webmail for my system users, all I get is the php code, and not the actions, instead of the login page, I get text, being the code of the file. PHP somehow got disabled or something?

    httpd still loads php up, but my presetup domain, which does still work, just has lost php support...how can I get that running again?

    I have joomla installations and stuff used for testing purposes, but they dont work now bcos PHP suddenly isnt working for it.

    I use alot of the user directories, so, domain.com/~user/joomla for example.

    my webmail on domain.com/webmail, also setup with a subdomain (wihch still works) webmail.domain.com.


    My server works with a dynamic IP address, using a service from no-ip.com to keep the DNS upto date.

    Any ideas?

    Thank you in advance.
    ChildOTK
     
  2. ChildOTK

    ChildOTK New Member

    Ok...I figured it out


    Turns out my /etc/httpd/conf.d/php file had been modified, and so one option had been commented out, a vital line for my php to work, so now ive sorted that one out
     
  3. till

    till Super Moderator

    PHP must be commented out in this file if you want to use ISPConfig, otherwise the functions in ISPCofig to enable and disable PHP wont work.
     

Share This Page