PHP support for Jailkit user

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Dec 12, 2017.

  1. pawan

    pawan Member HowtoForge Supporter

    I am using Ubuntu 16.04 with default PHP7.
    and opt php both php5.4 and php5.3.29
    Using this instructions
    https://www.faqforge.com/linux/add-php-in-ssh-jail-ispconfig-3/
    I have modified it work with php 7.0 like
    Code:
    [php]
    comment = the php interpreter and libraries
    executables = /usr/bin/php
    directories = /usr/lib/php, /usr/share/php, /etc/php/7.0/, /usr/share/php-geshi, [B]/usr/share/zoneinfo[/B]
    includesections = env
    
    I also want to enable the PHP for php5.4 or 5.3 users.
    is it possible and how I can modify the above.

    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you might be able to add sections like [php53] and [php64] where you define which executables and folders shall be copied for that PHP versions. Or you add them all in the [ php ] section by adding the binary paths separated by comma in the executables line. I just spotted an error in the faqforge page, please remove the B in squared braces that are around the zoneinfo path.
     

Share This Page