PHP Sessions not working on one site!

Discussion in 'General' started by badben, Aug 21, 2006.

  1. badben

    badben ISPConfig Developer ISPConfig Developer

    I have ispconfig running on mandrake 10.2 using perfect setup.

    The problem is that on one of my sites sessions don't work and on the others they do.

    On the site that they don't work zencart is installed in folder web/zencart/ and sessions are set to be stored in a database.

    Does anybody know if this will change where sessions are stored for the whole site i.e a script in web/?

    there are no settings in the apache directives for either site and the site settings in ispconfig are identical for both sites.

    Ben
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is PHP Safe Mode enabled for that site? If so, have you tried to disable it?
     
  3. badben

    badben ISPConfig Developer ISPConfig Developer

    No PHP safe mode is not enabled.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Have you tried debugging the Zencart scripts?
     
  5. badben

    badben ISPConfig Developer ISPConfig Developer

    How do you mean?

    Sorry if that is a stupid question
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I mean putting some echo or print_r statements into the PHP scripts to see what it is doing at which stage.
     

Share This Page