PHP Script outsourcing

Discussion in 'Installation/Configuration' started by teves, Nov 27, 2006.

  1. teves

    teves Member

    Hi,

    I have a question about PHP scripts. I wish to place a friends' phpscript on my server, because he has no php at his provider. But when he puts in the link to my domain, the script will be downloaded instead of executed.
    I have a Suse 10.1 running (perfect setup), and in ISPconfig I have cgi and php enabled for my domain. I uploaded the script via ftp and changed the rights to -rwxr-xr-x afterwards.

    In the /var/log/apache2/error_log there are a lot of entries of the kind
    [Mon Nov 27 11:04:24 2006] [error] an unknown filter was not added: PHP
    exactly for those times I tried to execute the script.

    I viewed a few posts about this entry in the forum, but it didn't seem to be responsible for my issues.
    Can anyone help, please?

    Thank you,
    regards, Tom
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which file ending does the PHP file has that you uploaded and which script tags does the PHP script use, <?, <?php or <% ?
     
  3. teves

    teves Member

    The file ending is .php, but I already tried .php3 and .php4.
    The PHP-Tag is <?, but I also have tried <?php

    The php option to accept the <? tag (don't remember the options name) is enabled in php.ini

    I forgot to mention in my last post: I have already tried to allow php globally by un-commenting the mime-type and restarting apache. But this didn't work either.

    PHP did work when called from a site on the server itself; I put a phpinfo() into the startpage of my domain and it worked perfectly.

    regards, Tom
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. teves

    teves Member

    Hello,

    thanks for your help.
    It is correct, that after the changing of /home/admispconfig/ispconfig/lib/config.inc.php
    the error message in /etc/log/apache2/error.log disappears, but this doesn't solve my problem.

    As I said I have a webpage on server a calling a php script on server b (which is the one in question). Instead of running the script it is downloaded.

    regards, Tom
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you place the script in a web site created with ISPConfig? Is PHP enabled for that web site?
     
  7. teves

    teves Member

    Yes and yes.

    BTW, for the first time I downloaded the given file and it is NOT the php file but the following:

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>500 Internal Server Error</title>
    </head><body>
    <h1>Internal Server Error</h1>
    <p>The server encountered an internal error or
    misconfiguration and was unable to complete
    your request.</p>
    <p>Please contact the server administrator,
    [email protected] and inform them of the time the error occurred,
    and anything you might have done that may have
    caused the error.</p>
    <p>More information about this error may be available
    in the server error log.</p>
    <p>Additionally, a 500 Internal Server Error
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache/2.2.0 (Linux/SUSE) Server at www.mydomain.de Port 80</address>
    </body></html>


    This is very strange, because I'm using the german language in ISPconfig...:confused:

    regards, Tom
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in Apache's error log?
    What's the full path to the PHP script? Can you post its URL here?
     

Share This Page