PHP reports deprecated function get_magic_quotes_runtime() in ispconfig scripts

Discussion in 'ISPConfig 3 Priority Support' started by DrMartinus, Aug 13, 2020.

  1. DrMartinus

    DrMartinus Member HowtoForge Supporter

    This seems to appear only in one file,
    on line 48. I guess that's nothing to worry about, but at least I wanted to inform you about it. My PHP version is 7.4.9.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. DrMartinus

    DrMartinus Member HowtoForge Supporter

    Thanks for your reply. However, as fas as I know, PHP versions < 7.x are no longer supported, i.e. they have reached their "End of Life" already more than a year ago, meaning that there are also no necessary security fixes. Hence the developers of PHP urge users to update to 7.x, preferably 7.4. This background should also force ISPConfig to support PHP 7.x (and stop supporting older versions of PHP).
    PHP 5.4 has not been patched since 2015.
    If ISPConfig ist still relying on this version, it takes risks that aren't necessary.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not the case, I nowhere said that. Please reread my answer in #2

    1) Where did I mention PHP 5.x?
    2) Where di I claim that you must install PHP 5.x to use ISPConfig?
    3) Where did I say that you can't use PHP 7.4?

    Nothing of that is said in my post, so your whole rant is completely off.

    All I told you that you are using an ISPConfig version that is not compatible with your installed PHP version and that's why you get that warning displayed.

    ISPConfig 3.1.15p3 is compatible with PHP up to 7.3 as PHP 7.3 is the highest PHP version used by any OS that's supported by ISPConfig 3.1.15p3. The latest ISPConfig (which is currently 3.1dev and will become 3.2) is already compatible with PHP 7.4 for quite some time, I posted even the link which shows that.
    Th0m likes this.
  5. DrMartinus

    DrMartinus Member HowtoForge Supporter

    Sorry if it appeared to you as if I was ranting - I wasn't. I was just trying to express my concern.

    Regargind your questions:
    1) You did mention it indirectly by linking to your reply in In that reply you said one should stick with the PHP version which is provided by the OS on the server. That would be 5.4 in my case (CentOS 7). For CentOS 7 the default PHP version is 5.4.
    2) You didn't say that, But I didn't imply that you said that, either.
    3) See above my response to No. 1. Your reply in that post implies that one should use PHP 5.4, because that's the default version that comes with CentOS 7 (you said there: "do not change the default PHP version of an OS").

    Please, I'm not looking for a fight or so, I just want to get things straight. I am concerned about the safety of my server, hence I need to make sure I have done all I can and is possible to ensure that safety. I'm looking forward to ISPConfig 3.2.
    Last edited: Aug 21, 2020
    Th0m likes this.

Share This Page