PHP problems after update to Debian Wheezy

Discussion in 'Installation/Configuration' started by Kira, May 30, 2014.

  1. Kira

    Kira Member


    I recently upgraded my system to Debian Wheezy (7.5).
    Now, I seem to have some problems with my PHP setup.. whenever I try to load the admin portal of ISPConfig or my Webmail Roundcube, I get Internal Server Errors and the apache error log is getting filled up with:


    I googled a bit and found some solutions.. like, for the first problem to edit the suphp.conf and add the directory to docroot, but then I get those error messages:

    For the other error I removed "allow_call_time_pass_reference" from /etc/php5/apache2/php.ini - but that didn't change anything :(

    Any help would be appreciated! :)

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Kira

    Kira Member

    Thanks a lot for the quick response!

    I followed your instructions and edited the suphp.conf - it works now :)
    The problem about /usr/local doesn't show up anymore either.

    The only problem I now still have is:

    Any idea?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    remove the suhosin ini from /etc/php5/conf.d/ as suhosin is not available anymore in that php version.
  5. Kira

    Kira Member

    Only one line of the error message left now :D

    Thank you so much! I know this is not directly related to ISPConfig.. so really thank you very much for helping me that quick :)

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason for "allow_call_time_pass_reference" error is that this setting is not supported anymore in the new php version. so the fix is to remove that settings. But the place were it has to be removed can differ. This can be a php.ini file, a custom php.ini (in ispconfig website settings) or even a .htaccess file. So you should start to search in the php.ini files and then check the .htaccess and custom php.ini field of the website.
  7. Kira

    Kira Member

    It was hidden in /etc/php5/cgi/php.ini - thanks a lot! :)

Share This Page