PHP problem ..Just installed ISP Config

Discussion in 'Installation/Configuration' started by malikp, Apr 9, 2006.

  1. malikp

    malikp New Member

    I just installed ISP config on Ubuntu Breezy 5.10
    Web server, email and DNS works fine.
    I try to install SquirrelMail and get is to this PHP problem
    I configure the SquirrelMail
    and try to access the log in page and get this error
    http://mail.test.com

    <?php

    /**
    * index.php
    *
    * Redirects to the login page.
    *
    * @copyright &copy; 1999-2006 The SquirrelMail Project Team
    * @license http://opensource.org/licenses/gpl-license.php GNU Public License
    * @version $Id: index.php,v 1.14.2.7 2006/02/03 22:27:46 jervfors Exp $
    * @package squirrelmail
    */

    // Are we configured yet?
    if( ! file_exists ( 'config/config.php' ) ) {
    echo '<html><body><p><strong>ERROR:</strong> Config file ' .
    '&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
    'configure SquirrelMail before you can use it.</p></body></html>';
    exit;
    }

    // If we are, go ahead to the login page.
    header('Location: src/login.php');

    ?>​

    Then I try to create this a test page with following then I can see same thing in the web browser.

    <?php
    phpinfo();
    php?>​

    But ISP config works fine. I have no idea what else to look.
    May be PHP configure for ISP Config only for apache 1.3 not for apache2. Is that the case how can I configure PHP for Apache2.
    Thank you,
     
    Last edited: Apr 9, 2006
  2. awd.pt

    awd.pt New Member

    This is nothing related with ISPConfig since ISPConfig runs a separated HTTP server.
    I've recently a problem like yours and it was related with apache configuration and php module (I had a mess of php-4 and php-5 :eek: ). I solved by rpm -e php httpd and yum -y install httpd php. Not the right or best way to solve it, but it worked for me.

    srosa
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you create the website mail.test.com in ISPCOnfig? If yes, did you check the php cgeckbox for the site?

    Be aware that ISPConfig has to deactivate your PHP installation in httpd.conf globally and re enables it for every website.
     
  4. malikp

    malikp New Member

    Mange to fix the problem


    i remove php4 and reinstall but did not fix.
    Then I install php5 and now all working. I do not know how its fix but now all working.

    Thank you all helping me
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I hope you installed Squirrelmail in a web site you created with ISPconfig and not in the default directory /var/www.
     
  6. malikp

    malikp New Member


    Yes... not in the /var/www

    and now its working fine
     

Share This Page