Discussion in 'Installation/Configuration' started by samtito, Feb 28, 2008.

  1. samtito

    samtito New Member

    I have successfully installed ISPCONFIG 2.2.19 and updated it to 2.2.21 to support php-pear and pear::db but i keep getting this error with my database connection page:

    == start
    PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'DB.php' (include_path='.:/usr/share/pear')
    === END

    Also a phpinfo() page shows that pear is not installed. How can i fixed this problem?

    Thank you
  2. samtito

    samtito New Member

    Here is part of the logs from the installation which showed that pear got installed

    [PEAR] PEAR - installed: 1.6.1
    Wrote PEAR system config file at: /root/ispconfig/php/etc/pear.conf
    You may want to add: /root/ispconfig/php/lib/php to your php.ini include_path
    Installing PDO headers: /root/ispconfig/php/include/php/ext/pdo/

    Any help will be appreciated, thank you.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig neither uses PEAR nor NEED it. If you want to use pear in a website, this has nothing to do with ISPConfig, just install the pear package from your linux distribution and then install the pear DB package.

    Do not chang anything in the path /root/ispconfig/php/, this has nothing to do with PHP in your websites. Please undo all changes you made there.
  4. samtito

    samtito New Member

    Thank for the reply, I restored my configuration from a backup and install installed pear DB, as suggested (php-pear is already installed) but my code still did not work.

    I remember the initial setup disbled pear for php in the compile options. On line 129 of the file install_ispconfig/compile_aps/compile (ver 2.2.21)

    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL } --disable-libxml --disable-dom --disable-xml ${WITH_ZLIB_DIR} --disable-xmlreader --disable-xmlwriter --disable- simplexml --without-pear || error "Could not configure PHP"

    So my php info page shows no pear installed . I am running centos 5 x86_64, and rpm -qa|grep php displays the following


    Any ideas? Thank you.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up things!

    Thats wrong as this has nothing to do with your websites!

    Please do not touch the ISPConfig PHP, it has absolutely nothing to do with the websites that you run on your server. The same goes for install_ispconfig/compile_aps/compile, this is only for ispconfigs internal purposes and not used for the websites! So do not change this.

    Please modify check php config files in /etc/ as I told you above!

Share This Page