php-pdo 5.3.3 required

Discussion in 'HOWTO-Related Questions' started by conductive, Oct 4, 2011.

  1. conductive

    conductive Member

    php-mssql dependancy -- php-pdo 5.3.3 required

    I am failing step 15
    Installing Apache2 With mod_php, mod_fcgi/PHP5, And suPHP

    yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-eaccelerator php-mbstring php-mcrypt php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel

    Since php-pdo 5.3.2 is installed and 5.3.3 is required for php-mssql

    How can I remove php-pdo 5.3.2 and replace it with 5.3.3 or simply configure the repo to prevent this.
     
    Last edited: Oct 4, 2011
  2. Mark_NL

    Mark_NL New Member

    Step 15 of what? Which how-to did you use?
     
  3. conductive

    conductive Member

  4. conductive

    conductive Member

    This is quite simple.

    All servers that use mssql-devel are hosed unless somebody knows how to find, get or compile php-pdo-5.3.3-3.el6.??????.rpm
     
  5. conductive

    conductive Member

    Found it but I do not know how to download it into a server and then remove the old rpm and replace it with this one.

    Maybe there is a way to modify the repo and update.
     
  6. conductive

    conductive Member

    I was able to download php-pdo but it appears that mssql-devel revision is out of sync with the rest of php-5.3.2-6

    This file is tied to php-common, php-mbstring, php-cli, php-mysql, php-5.3.2-6, php-imap, php-gd, php-xml, php-odbc, php-ldap and php-xmlppc.

    Most of these files are loaded with phpmyadmin
     
  7. bigfoot3d

    bigfoot3d New Member

    Any Resolution?

    I am running into the same issue, have you resolved your issue? If so can you post how you resolved it?

    Thanks!
     
  8. conductive

    conductive Member

    Welcome to rpm/yum dependency HeLL!
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Did you set up all repos as shown in the tutorial? Do you use a 32- or 64-bit system?
     
  10. conductive

    conductive Member

    I do not recall this happening before. I think this is a new development in PHP but I could be wrong.
     
  11. bigfoot3d

    bigfoot3d New Member

    I followed the tutorial step by step, and even scratched everything and reinstalled and started over from step 1 to make sure I didn't skip a step and I still run into the same issue. 64 bit system here.
     
  12. conductive

    conductive Member

    I think I tried both. the offending modules are loaded with phpmyadmin. It seems to me that if php was loaded/compiled or upgraded or downgraded prior to installing phpmyadmin it might work. I am not too good with repos so there may be an easy solution too.
     
  13. kephra

    kephra New Member HowtoForge Supporter

    I tried setting up Perfect Server (ISPCONFIG 3) on Centos 6 and got the same problem. I followed your tutorial to the letter, installing on a fresh Centos 6 installation.

    The strange thing is that this worked perfectly a couple of weeks ago when I installed it on another pc.

    If you have a solution, I would be most grateful.

    I am using the x86_64 versions.

    Bill
     
    Last edited: Oct 10, 2011
  14. maxtorzito

    maxtorzito New Member

    I have the same problem!!
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Such probems are common for centos as the required packages are spread over many independant repositorys. So you will get such problems on a centos server sooner or later when you run updates even when the initial install succeeded.

    I can only recommend you to use debian instead. Debian has one integrated repository which contains all packages, so no dependency hell as on centos. And debian is the most stable linux distribution for ispconfig.
     
  16. conductive

    conductive Member

    Is 5.3.3 even considered to be a stable number by *nx conventions?

    This could have been the one with the warning about the repo being modified outside of the ??????? or something?
     
  17. bigfoot3d

    bigfoot3d New Member

    Guess I'll move on with Debian instead of Centos...
     
  18. Sevastian1711

    Sevastian1711 New Member

    anything new? I have the same probelma with PHP-DO.
    I finished the installation but does not work :(
     

Share This Page