PHP pages displaying blank

Discussion in 'General' started by tristanlee85, May 22, 2010.

  1. tristanlee85

    tristanlee85 New Member

    After tracking it down, the error seems to be related to the open_basedir (according to the error log), but the file being access does seem to be within the list of directories.

    [Fri May 21 20:07:04 2010] [error] [client] PHP Warning:  Unknown: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web10/web:/var/www/clients/client1/web10/tmp:/var/www/ in Unknown on line 0
    [Fri May 21 20:07:04 2010] [error] [client] PHP Fatal error:  Can't load /var/www/, open_basedir restriction. in Unknown on line 0
    And the vhost file:

    <Directory /var/www/>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    <VirtualHost *:80>
          DocumentRoot /var/www/
        ServerAdmin [email protected]
        ErrorLog /var/log/ispconfig/httpd/
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        <Directory /var/www/>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        <Directory /var/www/clients/client1/web10/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i [email protected]"	
        php_admin_value upload_tmp_dir /var/www/clients/client1/web10/tmp
        php_admin_value session.save_path /var/www/clients/client1/web10/tmp
        php_admin_value open_basedir /var/www/clients/client1/web10/web:/var/www/clients/client1/web10/tmp:/var/www/
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web10 client1
    I've tried adjusting the open_basedir value to just the /var/www/ value there I know the file is and it still errors out.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Which PHP method did you select in this website?
    2) Post the output of:

    ls -la /var/www/
  3. tristanlee85

    tristanlee85 New Member

    I am using mod_php.

    I tried the script at 644 and 755.
    [root@ns ~]# ls -la /var/www/ 
    -rwxr-xr-x 1 web10 client1 167 2010-05-21 20:28 /var/www/

Share This Page