PHP not working

Discussion in 'Installation/Configuration' started by Robear, Nov 21, 2017.

  1. Robear

    Robear New Member

    After I upgraded Ubuntu from 12.04 to 14.04, I couldn't get any sites up. I followed a guide on here to resync ispconfig. That has allowed me to get html pages to work, but PHP pages will not. I get an error: No input file specified.
    I'm unable to test my system with the script here: hxxps://www.howtoforge.com/community/threads/please-read-before-posting.58408/
    I did check the error logs at /var/log/apache2/ and /var/www/yourdomain.tld/log/
    The log for /var/www/yourdomain.tld/log/ was 0kb
    I've searched the forums here and google and I'm not sure where to look or what to do next. Please may I have guidance.

    Log from /var/log/apache2/
    [Mon Nov 20 06:25:46.637053 2017] [auth_digest:notice] [pid 5472] AH01757: generating secret for digest authentication ...
    [Mon Nov 20 06:25:46.643492 2017] [:notice] [pid 11747] FastCGI: process manager initialized (pid 11747)
    [Mon Nov 20 06:25:46.755631 2017] [:notice] [pid 5472] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Mon Nov 20 06:25:46.755668 2017] [:notice] [pid 5472] mod_python: using mutex_directory /tmp
    [Mon Nov 20 06:25:46.797570 2017] [ssl:error] [pid 5472] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / issuer: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / serial: BD704C57E8E68762 / notbefore: Aug 10 01:53:19 2013 GMT / notafter: Aug 8 01:53:19 2023 GMT]
    [Mon Nov 20 06:25:46.797595 2017] [ssl:error] [pid 5472] AH02235: Unable to configure server certificate for stapling
    [Mon Nov 20 06:25:46.797612 2017] [ssl:warn] [pid 5472] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Nov 20 06:25:46.797629 2017] [ssl:warn] [pid 5472] AH01909: RSA certificate configured for hostmeh.com:8080 does NOT include an ID which matches the server name
    [Mon Nov 20 06:25:46.798152 2017] [mpm_prefork:notice] [pid 5472] AH00163: Apache/2.4.7 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.21 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations
    [Mon Nov 20 06:25:46.798170 2017] [core:notice] [pid 5472] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Nov 20 06:25:46.798234 2017] [mpm_prefork:warn] [pid 5472] AH00167: long lost child came home! (pid 20199)
    [Mon Nov 20 06:25:46.798276 2017] [mpm_prefork:warn] [pid 5472] AH00167: long lost child came home! (pid 20203)
    PHP Fatal error: xc_fcntl_create: open(/var/www/clients/client0/web12/tmp/.xcache.5012.498.1.mutex, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    PHP Fatal error: xc_fcntl_create: open(/var/www/clients/client0/web12/tmp/.xcache.5012.498.2.mutex, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Just guessing, but you could try disable xcache. Run through the ubuntu 14 perfect server guide and make sure you haven't missed anything after the update.
     

Share This Page