php not working

Discussion in 'General' started by asgare, Sep 27, 2017.

  1. asgare

    asgare Member

    I really shame to explain recent problem with ISPConfig
    Finally after all disasters new server come up with latest ISPConfig and Debian 9.1.
    Now after adding a website, php pages not browsing.
    As you see in attachment I have tried all PHP forms like FAST-CGI, CGI, PHP-FPM etc but still php pages not compiles. Even I don't know how to use these (FAST-CGI, CGI, PHP-FPM)

    please help :((((

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I assume you followed this tutorial to install ISPconfig:

    1) Set the php mode to php-fcgi or php-fpm and wait 2 minutes (until the red dot in the navigation bar disappears).
    2) Create a file info.php in the 'web' folder of the website with this content inside the file:


    Ensure that the file is owned by the web user and client group of the website. When you upload the file by FTP with an FTP user of th website, then it has always the right owner.
    3) now open the URL to the file in the browser:


    what exactly do you get in the browser?
  3. asgare

    asgare Member

    Hi till
    Have missed you for long time :) somehow love this kind of problems since cause of meeting you :D
    You are awesome, problem solved!

    One thing more, do you have any interest upon this thread?

Share This Page