PHP Not working

Discussion in 'Installation/Configuration' started by estebanmora, May 17, 2009.

  1. estebanmora

    estebanmora New Member

    I don't know what is happening what suddenly the PHP of my ISPConfig box stop working. If I create a file named index.php with:

    <?php
    phpinfo();
    ?>

    I only receive this on my browser:

    <?php
    phpinfo();
    ?>

    Only the contents of the file appears. I search in this forum for someone having the same problem with no one with the same exactly. The only way in which I can make the script work is enabling php globally. The strange part is that PHP was working on the server last week without problems. No updates have been made. The websites are created with PHP scripts checked but not with Secure PHP.

    There has to be something wrong with the server because now, when I create a new website, when I type the domain address in my browser I end in the /var/www forlder instead of the domain folder.

    I need some help here.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, then you dont have a problem with php, you access your sites not trogh their vhosts. Instead you access them now trogh the global vhost.

    Either you installed any software package which chnaged the global vhost of your linux distribution or something in dns has been changed.

    To fix this, make sure that you selected the correct IP addresses for the websites in ispconfig instead of *
     
: ispconfig2

Share This Page