PHP not working

Discussion in 'General' started by jefash, Aug 22, 2005.

  1. jefash

    jefash New Member

    ok, i have ispconfig installed on fedora core 4 following "the perfect setup" on, but my php forms do not work correctly, my forms get emailed to me , but no data, just the fields, if i host the form from, it processes fine and all data gets sent to me, btw, i had to change the default port 81 to 82 per instructions i found as i use ipcop and it wont budge off of port 81, also, am i understanding correctly that ispconfig and the apache web server it controls arent one and the same, that ispconfig runs on apache 1.33 on port 81, and apache 2 runs on port 80

    i have php scripts enabled for the sites, i have tried it with safemode on and off, same thing, when php is disabled for the site in ispconfig i get the errors that i should since php scripts are disabled, any ideas?

    this is from the info.php from the sticky thread

    PHP Core
    Directive Local Value Master Value
    allow_call_time_pass_reference Off Off
    allow_url_fopen On On
    always_populate_raw_post_data Off Off
    arg_separator.input & &
    arg_separator.output & &
    asp_tags Off Off
    auto_append_file no value no value
    auto_globals_jit On On
    auto_prepend_file no value no value
    browscap no value no value
    default_charset no value no value
    default_mimetype text/html text/html
    define_syslog_variables Off Off
    disable_classes no value no value
    disable_functions no value no value
    display_errors Off Off
    display_startup_errors Off Off
    doc_root no value no value
    docref_ext no value no value
    docref_root no value no value
    enable_dl On On
    error_append_string no value no value
    error_log no value no value
    error_prepend_string no value no value
    error_reporting 2047 2047
    expose_php On On
    extension_dir /usr/lib/php/modules /usr/lib/php/modules
    file_uploads On On #FFFFFF #FFFFFF
    highlight.comment #FF8000 #FF8000
    highlight.default #0000BB #0000BB
    highlight.html #000000 #000000
    highlight.keyword #007700 #007700
    highlight.string #DD0000 #DD0000
    html_errors On On
    ignore_repeated_errors Off Off
    ignore_repeated_source Off Off
    ignore_user_abort Off Off
    implicit_flush Off Off
    include_path .:/usr/share/pear .:/usr/share/pear
    log_errors On On
    log_errors_max_len 1024 1024
    magic_quotes_gpc Off Off
    magic_quotes_runtime Off Off
    magic_quotes_sybase Off Off
    mail.force_extra_parameters no value no value
    max_execution_time 30 30
    max_input_time 60 60
    memory_limit 8M 8M
    open_basedir no value no value
    output_buffering 4096 4096
    output_handler no value no value
    post_max_size 8M 8M
    precision 14 14
    register_argc_argv On On
    register_globals Off Off
    register_long_arrays Off Off
    report_memleaks On On
    report_zend_debug On On
    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir no value no value
    sendmail_from no value no value
    sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
    serialize_precision 100 100
    short_open_tag On On
    SMTP localhost localhost
    smtp_port 25 25
    sql.safe_mode Off Off
    track_errors Off Off
    unserialize_callback_func no value no value
    upload_max_filesize 2M 2M
    upload_tmp_dir no value no value
    user_dir no value no value
    variables_order EGPCS EGPCS
    xmlrpc_error_number 0 0
    xmlrpc_errors Off Off
    y2k_compliance On On
    zend.ze1_compatibility_mode Off Off

    Apache Version Apache/2.0.54 (Fedora)
    Apache API Version 20020903
    Server Administrator [email protected]
    User/Group apache(48)/48
    Max Requests Per Child: 4000 - Keep Alive: off - Max Per Connection: 100
    Timeouts Connection: 120 - Keep-Alive: 15
    Virtual Server Yes
    Server Root /etc/httpd
    Loaded Modules core prefork http_core mod_so mod_access mod_auth mod_auth_anon mod_auth_dbm mod_auth_digest util_ldap mod_auth_ldap mod_include mod_log_config mod_logio mod_env mod_mime_magic mod_cern_meta mod_expires mod_deflate mod_headers mod_usertrack mod_setenvif mod_mime mod_dav mod_status mod_autoindex mod_asis mod_info mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_actions mod_speling mod_userdir mod_alias mod_rewrite mod_proxy proxy_ftp proxy_http proxy_connect mod_cache mod_suexec mod_disk_cache mod_file_cache mod_mem_cache mod_cgi mod_perl mod_php5 mod_python mod_ssl

    Directive Local Value Master Value
    engine 1 1
    last_modified 0 0
    xbithack 0 0

    Apache Environment
    Variable Value
    HTTP_ACCEPT image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/, application/, application/msword, */*
    HTTP_ACCEPT_ENCODING gzip, deflate
    HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
    HTTP_COOKIE lang=english; admin=YWRtaW46ZTYxYmEzYjAxZDk3ODE0ODBkMDEzY2FmNDhmYWUzNDM6
    PATH /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
    SERVER_SIGNATURE <address>Apache/2.0.54 (Fedora) Server at Port 80</address>
    SERVER_SOFTWARE Apache/2.0.54 (Fedora)
    DOCUMENT_ROOT /home/www/web4/web
    SERVER_ADMIN [email protected]
    SCRIPT_FILENAME /home/www/web4/web/info.php
    REMOTE_PORT 2821
    QUERY_STRING no value
    REQUEST_URI /info.php
    SCRIPT_NAME /info.php

    HTTP Headers Information
    HTTP Request Headers
    HTTP Request GET /info.php HTTP/1.1
    Accept image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/, application/, application/msword, */*
    Accept-Language en-us
    Accept-Encoding gzip, deflate
    User-Agent Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
    Connection Keep-Alive
    Cookie lang=english; admin=YWRtaW46ZTYxYmEzYjAxZDk3ODE0ODBkMDEzY2FmNDhmYWUzNDM6
    HTTP Response Headers
    X-Powered-By PHP/5.0.4
    Connection close
    Transfer-Encoding chunked
    Content-Type text/html; charset=UTF-8

    MySQL Support enabled
    Active Persistent Links 0
    Active Links 0
    Client API version 4.1.12
    MYSQL_MODULE_TYPE external
    MYSQL_SOCKET /var/lib/mysql/mysql.sock
    MYSQL_INCLUDE -I/usr/include/mysql
    MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient

    Directive Local Value Master Value
    mysql.allow_persistent On On
    mysql.connect_timeout 60 60
    mysql.default_host no value no value
    mysql.default_password no value no value
    mysql.default_port no value no value
    mysql.default_socket no value no value
    mysql.default_user no value no value
    mysql.max_links Unlimited Unlimited
    mysql.max_persistent Unlimited Unlimited
    mysql.trace_mode Off Off

    MysqlI Support enabled
    Client API version 4.1.12
    MYSQLI_SOCKET /var/lib/mysql/mysql.sock

    Directive Local Value Master Value
    mysqli.default_host no value no value
    mysqli.default_port 3306 3306
    mysqli.default_pw no value no value
    mysqli.default_socket no value no value
    mysqli.default_user no value no value
    mysqli.max_links Unlimited Unlimited
    mysqli.reconnect Off Off
    Last edited: Aug 22, 2005
  2. Tribal-Dolphin

    Tribal-Dolphin ISPConfig Developer ISPConfig Developer


    Your PHP works fine ! but you have a problem with the configuration.
    Edit php.ini file and do this :
     register_globals On
    and try again.
  3. falko

    falko Super Moderator ISPConfig Developer

  4. jefash

    jefash New Member

    thank you, worked perfect, i scoured the internet for 2 days and didnt find that
  5. K_meleonu

    K_meleonu New Member

    I have that blank page problem with .php ... i searched and readed on this forum all the posts regarding that problem but it seemn nothing work's to me. I installed a Mambo web site and when i try to access it i get a blank page.
    Also i made a simple php mailer, it is working but i o not receive the e-mails i send with it.
    Can someone help me? I whould be more than gratefull... Thank you all in advance
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you create a web site for Mambo with ISPConfig? Make sure you do not enable PHP Safe Mode for that web site.
    Regarding your email problem: any errors in the mail log?
  7. K_meleonu

    K_meleonu New Member

    About the email problem : I will post the errors here:

    Regarding the php problem:
    Yes it's about a Mambo web site but i have the php safe mode disabled
    I also triyed with a php nuke web site. After install i also have a white page.


    Thank you a lot in advance
  8. falko

    falko Super Moderator ISPConfig Developer

    Anything in your Apache error log? Is there an .htaccess file in your web root? If so, what's in it?
  9. K_meleonu

    K_meleonu New Member

    I only have .htpasswd .
    But i don't think that is a problem. I have no apache errors. i have restarted it and all workt ok. I also installed a phpBB2 forum and that is working great. no problems at all... i triyed with a php made web site and it also works great.
    i don't know what to do to make this work. :( :mad: :(
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    locate .htaccess
  11. itgroup

    itgroup New Member


    Just thought I would post this as it might help someone. I guess by now you have fixed this problem, but often - blank pages in PHP are caused by lack of memory in php.ini. By default. php allocates only 8mb - change this to 32 or 64 and restart httpd service.

Share This Page