php not working for just one site

Discussion in 'General' started by mmidgett, Aug 10, 2011.

  1. mmidgett

    mmidgett Member

    I have one site that will not display any php. Can you help me find out why. All other sites just work just fine. HTML works as expected.

    I am getting segmentation faults in my error logs, can this be the cause of it.

    I am using ubuntu 10.04 32bit on this virtual host. Initially I had down graded php when 5.3 was released. I have then moved to 5.3 and everything was working fine for 2 weeks then the client called and said the site wasn't working. I almost didn't believe them because all other sites are not affected.

    Its a Joomla 1.6 site that I'm having issues with.
     
  2. mmidgett

    mmidgett Member

    Update

    I deleted the site and waited a few and re-created the site. Then my php info test worked but when I unzipped the site and put it back it still doesn't load. I'm Kinda scratching my head on this one, I have checked ownership and file permissions but cant figure it out. I have turned off SEF and still nothing goes. I'll have to look further now I can get a php info test to display.

    If you want I'll give the line for the php test
     
    Last edited: Aug 12, 2011
  3. falko

    falko Super Moderator ISPConfig Developer

    Can you post the errors from the Apache error log?
     
  4. mmidgett

    mmidgett Member

    mmidgett@webster:~$ sudo /usr/local/ispconfig/server/server.sh
    finished.
    /usr/local/ispconfig/server/server.sh: line 7: 17318 Segmentation fault /usr/bin/php -q /usr/local/ispconfig/server/server.php
    mmidgett@webster:~$ sudo service apache2 stop
    * Stopping web server apache2 [ OK ]
    mmidgett@webster:~$ sudo service apache2 start
    * Starting web server apache2 [ OK ]
    mmidgett@webster:~$ vi /var/log/apache2/error.log
    [Fri Aug 12 14:10:06 2011] [notice] child pid 18949 exit signal Segmentation fault (11)
    [Fri Aug 12 14:10:07 2011] [notice] child pid 18950 exit signal Segmentation fault (11)
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined variable: html_server in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 237, referer: https://webster.trickhosting.biz:8080/index.php
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: unknown in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 255, referer: https://webster.trickhosting.biz:8080/index.php
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: info in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 256, referer: https://webster.trickhosting.biz:8080/index.php
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: critical in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 258, referer: https://webster.trickhosting.biz:8080/index.php
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: error in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 259, referer: https://webster.trickhosting.biz:8080/index.php
    [Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined variable: description in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 72, referer: https://webster.trickhosting.biz:8080/index.php
    @ 10722,1 99%
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the errors from the error.log of the website that is not working. The errors you posted above are from the global error.log file.
     

Share This Page