php not working correctly

Discussion in 'General' started by rebeltaz, Mar 18, 2014.

  1. rebeltaz

    rebeltaz New Member

    Due to being hacked, I now have ufw firewall set to block all outside traffic except for ports 80 and 443. Could this possibly affect php's ability to be passed paramaters from the url?

    For instance:
    the filename is not being passed to the php script.

    neither the page filename (robots) or the digit (ocr) are being passed to the script.

    If the firewall has nothing to do with this, is there anything else that could cause it? Thanks.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The firewall should not affect passing parameters to a php script. But you can try to deactivate the firewall for a minute to see if it works then.

    Depending on the code of your script, it might be nescessary that you enable:

    register_globals = On


    register_long_arrays = On

    in the php.ini file.
  3. neutrino

    neutrino Member

    You should also check if you have a loopback on your firewall, if your server isn't allowed to talk to itself, many things will stop working.

    For example if you use iptable as firewall you should have this :

    iptables -A INPUT -i lo -j ACCEPT
    iptables -A OUTPUT -o lo -j ACCEPT
  4. rebeltaz

    rebeltaz New Member

    Modifying register_long_arrays in /etc/php/cgi/php.ini seems to have somewhat fixed the issue, but...

    echo "$ip";
    is returning:
    my local IP address (yes, repeated that many times) instead of my public IP address. It worked fine before this new reinstall. ??? Thanks.

Share This Page