PHP not upgraded to 5.2.5 ???

Discussion in 'Installation/Configuration' started by t.roijers, Apr 14, 2008.

  1. t.roijers

    t.roijers New Member


    I have ISPConfig Version: 2.2.21 installed.

    ISPConfig 2.2.19 released

    This ISPConfig release adds support for CentOS 4.6 and 5.1
    and updates ClamAV to 0.92 and PHP to 5.2.5. Several minor
    bugs were fixed.

    For a detailed list of changes please read the changelog.

    Since Version 2.2.19 there should be PHP 5.2.5 but mine 'newer' version is running PHP 5.0.4.

    Did something go wrong here?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you mix up the ISPConfig PHP and the PHP thats serves your websites. The ISPConfig PHP is for the controlpanel only. The PHP that serves your websites is from your linux distribution.
  3. t.roijers

    t.roijers New Member

    Php Ispconfig

    Sorry Till, your absolutly right!

    I have to upgrade my SuSe 10.0 but Novell no longer support 10.0.
    Now i have to find out if it's possible to upgrade 10.0 to OpenSuSe 10.3.

    Find a lot of info, but all with the same answer " DO A CLEAN INSTALL"
    Well, that's just not possible, if have numerous website's running on the ISP server.

    If i had to do a clean install i certainly would install Ubuntu instead.

    Tim Roijers
  4. t.roijers

    t.roijers New Member

    PHP 5.2.5 on suse 10 works, but not as i want to.

    Hello Till,

    maybe you can help me with this one.
    I want to configure PHP 5.2.5 for SuSe 10.0. I have found this:

    ./configure --prefix=/etc/php5/apache2 --with-apxs2=/usr/sbin/apxs2 –with-mysql=/usr/local/mysql --enable-soap=shared

    (hope i'm right with this)

    make install

    It works, i now have php 5.2.5 but the '--prefix=/etc/php5/apache2' and --enable-soap is not what i see in the phpinfo.

    phpinfo gives me:

    Configure Command './configure' '--prefix=/usr/local/php' '--with-apxs2=/usr/sbin/apxs2' '--with-mysql=/usr/local/mysql'

    Loaded Configuration File /usr/local/php/lib/php.ini

    and there's no SOAP what so ever.

    Any suggestions?

  5. falko

    falko Super Moderator ISPConfig Developer

    This means you're still using the old PHP installation. Please use the configure string of the old version when you're building the new one:

    ./configure --prefix=/usr/local/php --with-apxs2=/usr/sbin/apxs2 --with-mysql=/usr/local/mysql

Share This Page