PHP Multiple versions

Discussion in 'Installation/Configuration' started by kurdak, Nov 26, 2012.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact error messages do ou get in the error.log of the website? And the paths dont look right as thats not the path to the php binary, .../bin and ../lib are directories.
     
  2. jboud

    jboud New Member

    the error.log shows this:

    [Wed Jun 05 01:39:28 2013] [warn] [client xxx.xxx.xxx.xxx] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Jun 05 01:39:28 2013] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: index.php

    I changed the bin path to /opt/phpfarm/inst/bin/php-cgi-5.2.17 (this looks better?)
    and I can't find any other php.ini other than /opt/phpfarm/inst/php-5.2.17/lib/php.ini

    I would appreciate any suggestion as i'm not sure which is wrong, the paths or something on the website, although I migrated it from a debian lenny which means it was using php 5.2.17, right?
     
  3. stars

    stars New Member

    Any luck solving this problem?

    I installed Ispconfig 3.0.5.3 with PHP 5.3 and wanted to add PHP 5.2 support, everything went fine, but I also got erro 500...

    [EDIT] Ok, I needed to uncomment:
    Code:
    Unix user of processes
                    <value name="user">nobody</value>
    
                            Unix group of processes
                    <value name="group">nogroup</value>
    in /opt/php-5.2.17/etc/php-fpm.conf

    Now 5.2 works fine!
     
    Last edited: Sep 19, 2013

Share This Page