php module miss match

Discussion in 'ISPConfig 3 Priority Support' started by budgierless, Jul 6, 2019.

  1. budgierless

    budgierless Member

    I am using ubuntu 18.04 that comes with php7.2
    I used the tutoral to adding muilpal php versions to use with ispconfig3
    as i need php 5.2 i installed that with no problem, but when trying to install extentions, i get problems:
    Code:
    module compiled with module api=20090626 php compiled with module api=20100525
    i know this is about the phpize and php-config files, i've done this many times in past with know problem but this time i cant get it to work,
    for example i installing the php ffmpeg extenion and normally i would install using this method:
    Code:
    /opt/php-5.2.17/bin/phpize
    ./configure \
    --prefix=/usr/local/src/php5-build/php-5.2.17/ffmpeg-php \
    --with-ffmpeg=/usr/local/cpffmpeg \
    --with-php-config=/opt/php-5.2.17/bin/php-config
    make
    make install
    but the phpize output is:
    Code:
    phpize
    Configuring for:
    PHP Api Version:         20041225
    Zend Module Api No:      20060613
    Zend Extension Api No:   220060519
    
    please help!!!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks ok to me what you did. PHP 5.2 is really old and I'm not sure if you still can compile all modules for it on Ubuntu 18.04, so it might be that this module just can't be compiled anymore.
     

Share This Page