php mailer unreliable

Discussion in 'Installation/Configuration' started by Reptile, Feb 12, 2008.

  1. Reptile

    Reptile New Member

    I installed a new server using the Etch Perfect Setup. I have used this guide many times before and have never encountered such a problem.

    Since moving to the new server lots of customers are reporting lack of confirmation emails or no reply from our customer service panel.

    I run an smtp server on another machine in the same datacentre and this email system is reliable.

    So something is wrong with my php mailer on my main server. It isn't a problem with all email destinations, just many. Can anyone suggest things to look for in the configuration files, the dns etc etc because this is a huge problem right now.

    Is it possible to setup php to use my authenticated smtp server on the other machine so that I don't have to change all the code for the internal php mailer?
     
    Last edited: Feb 12, 2008
  2. Reptile

    Reptile New Member

    Just to let you know that i've just changed my scripts to use my other server's smtp facility.

    I'd still be interested to hear ideas on what's up though.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
     
  4. Reptile

    Reptile New Member

    There's nothing in the mail log because it was the php mail routine that was causing me problems.

    I should have clarified that the problem is solved by using smtp. But i'd still like to know what might be up with my php mail. Either there's a problem sending to some people it is being rejected.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Maybe the PHP mails are blocked for some reason. Does your server have a PTR and SPF record?
     
  6. Reptile

    Reptile New Member

    PTR, yes. SPF, I wasn't sure on how that configured properly because I use another server for the SMTP mail for that domain.
     
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page