PHP mail() not delivering mails ...

Discussion in 'Installation/Configuration' started by Berry, Nov 29, 2006.

  1. Berry

    Berry New Member

    Hi to all,

    I know there were many topic about non-working PHP mail() function with postfix, I've read them all but didn't find information how to fix it on my system. I hope you guys will help me out with this ...

    -> "perfect Sarge" + Postfix + Courier (like suggested in "perfect..." tutorial)
    -> POP3 / SMTP works just fine!
    -> Maildir option is turned on in ISPC
    -> PROBLEM: PHP mail() function doesn't get delivered

    from /var/log/maillog (notice there is NO dot between :confused: ):
    Code:
    Nov 29 14:40:29 localhost postfix/pickup[30231]: 9A5876DF6001: uid=10004 from=<tech5_admin>
    Nov 29 14:40:29 localhost postfix/cleanup[32198]: 9A5876DF6001: message-id=<[email protected]$
    Nov 29 14:40:29 localhost postfix/qmgr[30232]: 9A5876DF6001: from=<[email protected]>, size=434, nrcpt=1 ($
    Nov 29 14:41:00 localhost postfix/smtp[32200]: 9A5876DF6001: to=<[email protected]>, relay=mx01.t-com.hr[195.29.150.$
    Nov 29 14:41:10 localhost postfix/cleanup[32198]: A4E966DF6002: message-id=<[email protected]$
    Nov 29 14:41:10 localhost postfix/qmgr[30232]: A4E966DF6002: from=<>, size=2500, nrcpt=1 (queue active)
    Nov 29 14:41:10 localhost postfix/qmgr[30232]: 9A5876DF6001: removed
    Nov 29 14:41:10 localhost postfix/local[32242]: A4E966DF6002: to=<[email protected]>, relay=local, delay=0$
    Nov 29 14:41:10 localhost postfix/pickup[30231]: AE86C6DF6001: uid=10004 from=<tech5_admin>
    Nov 29 14:41:10 localhost postfix/qmgr[30232]: A4E966DF6002: removed
    Nov 29 14:41:10 localhost postfix/cleanup[32198]: AE86C6DF6001: message-id=<[email protected]$
    Nov 29 14:41:10 localhost postfix/qmgr[30232]: AE86C6DF6001: from=<[email protected]>, size=423, nrcpt=1 ($
    Nov 29 14:41:10 localhost postfix/local[32242]: AE86C6DF6001: to=<[email protected]>, relay=local, delay=0, $
    Nov 29 14:41:10 localhost postfix/qmgr[30232]: AE86C6DF6001: removed
    I've noticed that under "message-id" there is TLD stripped from my hostname, is this OK??

    -> there are no other logs for mail in /var/logs :confused:

    I will put here also copies of /etc/postfix/master.cf and /etc/postfix/local-host-names
     

    Attached Files:

  2. Berry

    Berry New Member

    Maybe this will help too :

    server02:~# netstat -tap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:pop3                  *:*                     LISTEN     10149/couriertcpd
    tcp        0      0 *:imap2                 *:*                     LISTEN     10125/couriertcpd
    tcp        0      0 *:www                   *:*                     LISTEN     11495/apache2
    tcp        0      0 *:81                    *:*                     LISTEN     11452/ispconfig_htt
    tcp        0      0 *:ftp                   *:*                     LISTEN     11635/proftpd: (acc
    tcp        0      0 server02.technoi:domain *:*                     LISTEN     11621/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     11621/named
    tcp        0      0 *:ssh                   *:*                     LISTEN     11405/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN     13392/master
    tcp        0      0 localhost:953           *:*                     LISTEN     11621/named
    tcp        0      0 *:https                 *:*                     LISTEN     11495/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN     10140/couriertcpd
    tcp        0      0 *:pop3s                 *:*                     LISTEN     10162/couriertcpd
    tcp        0      0 *:mysql                 *:*                     LISTEN     10223/mysqld
    tcp        0   1972 server02.technoizlo:ssh 83-131-23-29.adsl:62250 ESTABLISHED11745/0
    tcp        0      0 server02.technoizl:pop3 83-131-23-29.adsl:62260 TIME_WAIT  -

    server02:~# tail -f /var/log/maillog
    Code:
    Nov 29 15:46:11 localhost postfix/pickup[13394]: 25CA023F407B: uid=10004 from=<tech5_admin>
    Nov 29 15:46:11 localhost postfix/cleanup[15792]: 25CA023F407B: message-id=<[email protected]>
    Nov 29 15:46:11 localhost postfix/qmgr[13395]: 25CA023F407B: from=<[email protected]>, size=434, nrcpt=1 (queue active)
    Nov 29 15:46:19 localhost postfix/smtp[15794]: 25CA023F407B: to=<[email protected]>, relay=mx01.t-com.hr[195.29.150.90], delay=8, status=bounced (host mx01.t-com.hr[195.29.150.90] said: 550 <[email protected]>: Sender address rejected: Domain not found (in reply to RCPT TO command))
    Nov 29 15:46:29 localhost postfix/cleanup[15792]: 2882023F4088: message-id=<[email protected]>
    Nov 29 15:46:29 localhost postfix/qmgr[13395]: 2882023F4088: from=<>, size=2500, nrcpt=1 (queue active)
    Nov 29 15:46:29 localhost postfix/qmgr[13395]: 25CA023F407B: removed
    Nov 29 15:46:29 localhost postfix/pickup[13394]: 3132723F407B: uid=10004 from=<tech5_admin>
    Nov 29 15:46:29 localhost postfix/local[15812]: 2882023F4088: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 29 15:46:29 localhost postfix/qmgr[13395]: 2882023F4088: removed
    Nov 29 15:46:29 localhost postfix/cleanup[15792]: 3132723F407B: message-id=<[email protected]>
    Nov 29 15:46:29 localhost postfix/qmgr[13395]: 3132723F407B: from=<[email protected]>, size=423, nrcpt=1 (queue active)
    Nov 29 15:46:29 localhost postfix/local[15812]: 3132723F407B: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 29 15:46:29 localhost postfix/qmgr[13395]: 3132723F407B: removed
     
    Last edited: Nov 29, 2006
  3. falko

    falko Super Moderator ISPConfig Developer

    Please create a DNS record for server02.technoizlog.com. Also make sure your server isn't blacklisted: http://www.mxtoolbox.com/blacklists.aspx
     
  4. Berry

    Berry New Member

    There is already an A record for server02.technoizlog.com.
    And the blacklist check went OK too ...
     
  5. Berry

    Berry New Member

    SOLVED!

    appearently there was MX entry "server02.technoizlog.com" for this account, i chaned it to "domain.com" with host "www" and now it works fine!
     

Share This Page