php mail() doesnt work on suse

Discussion in 'HOWTO-Related Questions' started by linuxnewb999, Nov 22, 2006.

  1. linuxnewb999

    linuxnewb999 New Member

    I'm sorry for posting another thread about php mail when there is a similar one but i am not sure about the forum policies.

    I recently configured a windows and suse local systems for my intranet.

    On the windows machine, i configured the php.ini SMTP to point to my mail server with the ip address of and the php mail() scripts works perfect.

    But the problem occurs for the suse machine. I don't have a clue as to how to configure the php.ini to point to my mail server.

    What should i do on the suse machine to for this to work?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The php comes correctly configured on SuSe, you dont have to change anything in the php.ini. SuSe uses the locally installed mail daemon (postfix or sendmail or exim) to send the mail out.
  3. linuxnewb999

    linuxnewb999 New Member

    So it would be the mail daemon i would have to configure? Postfix is the default used by suse and i believe it is installed. Also i would like all mail to go through our smtp server, what files do i have to edit to have it running?
  4. linuxnewb999

    linuxnewb999 New Member

    Just found out how to get it to work. At least for my situation. Hope this may help others that runs into the same problem.

    What i did was went into the postfix file and find "relayhost" and pointed it to my mail server (

Share This Page